PC doesn't boot to BIOS?

Can't get to bios but PC powers up fine. Mobo an Asus Prime) shows orange DRAM Light (I run G.Skill Ripjaw V's x4, 16GB ea.) but sometimes gets past DRAM light only to get stuck on VRAM light. Have booted from motherboard GPU with one stick of reseated RAM in A1 slot (farthest from CPU) with video card taken out, no luck. Reseated CPU, changed to brand power supply, changed to alternate cooler. Mobo is brand new, high quality, and definitely not the problem. Tried flipping the MemOK switch and clearing the CMOS, unplugged the PC and flushed the power out of the system, no luck. No drives plugged in. Nothing that would cause a Mobo short to my knowledge. I have a beep code thingy if that helps. Tried a different stick of RAM and cleaned the RAM contacts. Is my CPU just dead? I checked the CPU contacts and they run fine. I have an Intel 6700 Skylake, not OC'ed. Again, I get different light codes after various combinations of flushing power and clearing CMOS. RAM should be compatible with the board (3200) but perhaps it is the problem. I bought this motherboard to replace my last one because my PC was failing to boot from that one as well. I don't have any money left to take it to a shop or order more RAM. Help me Obi Wan Kenobi, you're my only hope.

Update:

My Mobo is an Asus Prime Z390-A

3 Answers

Relevance
  • Lv 7
    2 months ago

    unplug your hard drive and try again.

  • 2 months ago

    you have to update your bios. You will need to download it from another computer onto a usb and when booting up you press f10 or f8 i cant remember. Install the updated bios and it should start up fine. I am not sure if this helps but hope it does.

  • 2 months ago

    please discover the mobo model number ... if you can't read it on the mobo, get the FCC number [which is required] and look it up in the FCC database.  with the model number, the Asus website can give you the troubleshooting guide so you'll know what that orange light does.  [all my lights are green, so I suspect that is trying to tell you what the problem is].

Still have questions? Get your answers by asking now.