zac asked in Computers & InternetSoftware · 1 month ago

Microsoft’s EDGE won’t allow Firefox to be my default browser. What can I do? I don’t want EDGE !?

10 Answers

Relevance
  • 4 weeks ago

    go to Settings, Apps, Default Programs, scroll down to web browser and select Firefox.

  • Dave
    Lv 7
    1 month ago

    There is nothing in Edge or Windows stopping an administrator from changing the default browser. You either do not have permissions on the device to do so, or you don't have a clue what you're doing.

    Either way, this is clearly a PEBKAC issue.

  • 1 month ago

    same problem i face dear friend

  • 1 month ago

    uninstall Microsoft Edge in windows 7 go to start, control panel, under programs-uninstall program then select Microsoft Edge (this will not work for internet explorer) there is no way to remove internet explorer

    Source(s): Comptia A+ and N+ Certs
  • How do you think about the answers? You can sign in to vote the answer.
  • 1 month ago

    It tried that foolishness with me and I just killed it by taking away its permissions.  I'm going to assume you are on Windows 10 Home edition.  You, as owner, should also be administrator.  Click on the lower left Window icon, then the gear symbol to get to settings.  Choose Apps, then Default Apps.  That should be enough.  I don't know if you can actually uninstall Edge, but it appears that I did so because it is not in my list of installed apps.

  • 1 month ago

    Lol! Type default apps into cortana scroll down to browser and click on Firefox. If it still won't let you charge then check in control panel to make sure you an administrator. If your a standard user you can't make changes

  • Lv 7
    1 month ago

    go to Settings, Apps, Default Programs, scroll down to web browser and select Firefox.

  • martin
    Lv 7
    1 month ago

    Go to those little dots in the upper right, click them, and delete all possible browsers except for the one you name as your default browser, under settings.

  • Bill-M
    Lv 7
    1 month ago

    Click on START then on Settings.

    In Settings select APPS -

    In the Left Column select Default Apps and scroll down to WEB BROWSER - Single Click on the ICON and in the pop up list select Firefox.

  • Alan
    Lv 7
    1 month ago

    You are aware that you must choose your default browser

    in Windows 10 through Settings->Apps-> Default Apps.

    You are not allowed to set it from Firefox in Windows 10.

    So don't try setting this from inside Firefox. 

    So if you are trying to do it correctly. 

    Then, keep reading. 

     

    It lets everyone else make Firefox their default browser 

    so there must be something wrong with your setup.  

    Such as you don't have an up-to-date version of Mozilla Firefox 

    properly installed on your computer. 

    You cannot make Firefox your default browser unless 

    it is already properly installed on your computer.    

Still have questions? Get your answers by asking now.