graphics card not working?

hello I wonder if anyone has any ideas please?

the bios is not recognising that the card is even plugged in, my BF is building a pc and has this problem. any ideas will help thanks 

Update:

It’s a Asus Prime-Z390 A and a Asus 2080 Super, 

test benched the system with air cooling CPU and GPU from box and it worked with the 2080 super, took apart the system, put in into the case , water cool CPU, put GPU into waterblock and now bios can’t see the 2080 Super,

Took loop apart, put GPU back into cooler and now the system won’t boot at all with the power to the GPU, 

I already updated the bios to current

And the firmware, and the chipset

Also it’s a RM 750x power supply

3 Answers

Relevance
  • 1 month ago

    If the system is new, then a problem with the Graphics card is possible. There could also be some sort of problem with the power supply. 

    If he's trying to put a new GPU into an older system that has an old BIOS, then there could be some issue. Some of the new graphics cards on the market will only work with motherboards that have the newer UEFI type of firmware. 

    • Commenter avatarLogin to reply the answers
  • David
    Lv 7
    1 month ago

    Need more information, make and model of motherboard, make and model of CPU and make and model of graphics card. Repost with this essential information until then no-one can help.

    • Commenter avatarLogin to reply the answers
  • H
    Lv 4
    1 month ago

    - Have you checked that the Graphics card and motherboard uses the same PCI Connection?

    - Have you installed all the correct drivers?

    - Is the Power supply powerful enough for the GPUs Power consumption?

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.