why my RAM kit stopped working after being used for a week?

I bought this ram Kit

(Corsair Vengeance LPX 16GB (2x8GB) DDR4 DRAM 2666MHz (PC4 21300) C16 Desktop Memory Kit - Black (CMK16GX4M2A2666C16)

for my computer ROG Strix GL10CS which had the same specifications. The ram sticks worked for a week and after a week, i got the blue screen with he below errors. Each time the computer was restating, i was getting one of these errors(stopcodes).

1- Memory management

2. Page_fault_in_nonpaged_area

what failed: tMUMH.sys

3-system_thread_exception_not_handled

My question is, is the problem caused by RAM sticks or the computer has problem?

When I put the old rams, everything came to normal and my computers works well. And if the rams were not compatible, why they were working for a week? Do I need to return the ram sticks or this problem could be fixed.. Please help

Attachment image

3 Answers

Relevance
  • 5 months ago
    Favorite Answer

    As it worked OK to start with, the most likely thing is that one RAM stick has failed.

    You could try each, one at a time, and run memtest86 - if one passes and one fails. just send them back for replacement.

    Electronic components usually either fail within the first few hours to weeks, or will probably last many years; it's called the "bathtub curve":

    https://www.itl.nist.gov/div898/handbook/apr/secti...

    Get memtest86 here and make a bootable disc or USB stick.

    Booting that directly avoids any chance of your operating system getting corrupted by repeated crashes while it is running. You can temporarily disconnect the normal boot if you want to avoid it starting the OS by accident.

    https://www.memtest86.com/

  • 5 months ago

    it needs to be tested by a technician

  • 5 months ago

    A BSOD that has a continuously changing error message is usually a memory-related issue.

    It is possible the RAM is DOA but more likely it's not configured correctly, or possibly your BIOS needs to be updated to support that RAM properly.

    Check for any BIOS updates for your PC, then go into your BIOS settings and check RAM configuration. If you don't have XMP enabled, then try enabling it and then run a benchmark or diagnostic such as Memtest86 to see if errors still occur.

    If XMP is enabled and you're still getting errors, try manually setting your RAM speed and timings, even if they're the same as what XMP tries to set, it does sometimes fix it.

Still have questions? Get your answers by asking now.