promotion image of download ymail app
Promoted

i need major help please...no trolls only serious question about my gaming computer?

first of all, the game sea of theives i have on here is not working when trying to launch it. and its from he microsoft store and is played by windows 10 so i uninstalled it and now i cant find out where to even go to reinstall it.

problem number 2: i tried to disabled or reset alot of apps on this pc like steam and after it restarted and all it wont even let m click on steam or a steam game without saying i need to reinstall it proof that im the real owner. something about adminstions and prevligious were at the end of the message i got.

WHAT DO I DO? this is stressing and i have a severe anxiety disorder

2 Answers

Relevance
  • 4 months ago
    Favorite Answer

    You give no clues on your hardware, so no guessing about that.

    The only suggestions possible are contact the people who do the games distribution for Microsnot and Steam.

    • michael4 months agoReport

      its an HP brand PC. and i think i rebooted the steam app or whatever because its not letting me click on steam or any steam games without having a message pop up bassicly wanting me to confirm that im the owner. yet when i click on "ok" its still not installing anything

    • Commenter avatarLogin to reply the answers
  • 4 months ago

    Try restarting the Microsoft Store application itself.

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.