I have a Canon 7DMII which I use with my Tamron 150-600 mm lens which I cannot get to any shutter speed higher than 1/800. Help.?

3 Answers

Relevance
  • 1 month ago

    Do you have auto ISO turned on with 800 as the upper limit?

    Are you in green box auto or exposure mode P (program auto)?

    Put the camera on M (manual) mode. Turn whichever dial adjusts the shutter speed (I don't remember and I have one). It should go over 800. If it does not, you have some sort of issue with your camera that needs professional care.

    • Login to reply the answers
  • Frank
    Lv 7
    1 month ago

    Which exposure mode are you in and how are you making your adjustment?

    If you're in aperture priority and you've chosen the largest aperture (either f/5.6 or f/6.3 depending on focal length) for your lens and your shutter speeds are still not beyond 1/800th, then the light level and/or your ISO is too low to allow the camera to choose 1/800th.

    But if you're in manual or shutter-priority mode and you can't choose  1/800th, then there's something else going on - possibly a broken camera.

    • Login to reply the answers
  • keerok
    Lv 7
    1 month ago

    Even in manual mode? That would be strange. You should be able to set it to 1/800s but if lighting is not enough, the resulting picture would be dark.

    If you are in any other mode, lighting is definitely not strong enough. Night-time, in your bedroom? Try setting ISO higher (say 3200) or you could use the flash.

    • Login to reply the answers
Still have questions? Get your answers by asking now.