Fix a LG HW300T Projector with dead inputs?

I have used my LG HW300T Projector for years and it has worked fine. However, about two months ago the HDMI (and VGA) port refuses to work.

The projector itself powers on and the projected image is fine, the built-in "smart" functions work as they should, the built-in USB port still powers items, however whenever I plug things into the HDMI or VGA port, I get the "no source found" blue screen.

I have not moved this projector for about a year and it worked perfectly until a few months ago.

Is there a way to reset the projector? Is this a known issue that can be fixed? Or is it dead?

Update:

The VGA Port Does work! 

3 Answers

Relevance
  • Lance
    Lv 7
    1 month ago

    It could be that you need a firmware update. HDMI is not a static format it evolves hence version 1.2 1.3 1.4 etc....basically the difference between the various versions besides the quality and functionality of the signal is the "handshake" involved. between components...In order for HDMI to work the two components send a hand shake signal... during this process the version and level of HDMI transmission is determined. If the handshake is from a very old version it may not work with newer components. Hence the need to update Firmware...Sometimes a newer firmware version is available sometimes not depending on how old your equipment is and weather the manufacture still supports the product or not.

    • Login to reply the answers
  • 1 month ago
    • Login to reply the answers
  • 1 month ago

    Try a new cable first.

    Video projector repair is such an extreme specialty

    that only a few shops in the entire US should be trusted with it.

    Shipping is one thing, but $300 and up for labour is another,

    so consider carefully before deciding what to do.

    • Login to reply the answers
Still have questions? Get your answers by asking now.