2003 eclipse loosing power?

I have a 2003 Mitsubishi Eclipse and this problem has been happening now for 3 months. The car would be driving fine and all of a sudden the TCL and ABS lights come on, on the dash, as well as the battery symbol. Everything looses power, and whenever I hit the brakes my music turns off on my radio. The headlights go dim, the windows struggle to come up, down. I tested the battery and alternator and everything is fine. Not sure what’s going on.

2 Answers

Relevance
  • 2 months ago

    Find a mechanic with a good scan tool to read the ABS codes. You'll find a front wheel speed sensor is setting the codes.

    In 2003 Mitsubishi's didn't have drive by wire so the ABS failure wouldn't cause a lack of power.

    Fix the the ABS problem first.

    If you still have other problems test the battery cables and take it from there.

    Source(s): Mitsubishi Master Tech
    • Login to reply the answers
  • Anonymous
    2 months ago

    "I tested the battery and alternator and everything is fine.".  If you used a carbon pile tester (load tester), then check for a bad block ground or body ground or a bad charging wire.  Get a wiring diagram for the alternator and check if the alternator is ECM controlled.  ECM might be bad. Check for trouble codes with a scanner to check for alternator trouble codes.

    If you did not use a carbon pile tester, go to a garage that has one and get the alternator and battery checked properly.

    • Login to reply the answers
Still have questions? Get your answers by asking now.