My dell laptop has a 6gb of dedicated video memory with a Geforce nvida graphics card, my videos are still slow wtf?

I got a brand new dell laptop. It has an Intel i5 cpu running at 2.60ghz quad core. 

8gb of internal memory. 512ssd hard disk drive. 

It has a dedicated video graphics card NVIDA with 6gb of dedicated video memory. 

It is rated as a gaming laptop not sure what rank. 

When the default app called 'movies and tv' opens a video the video is jerky and speeds up at first and then straightens up in the middle of the video. 

I don't see this issue with Windows media player or with VLC. I see it only with movies and t.v. app. 

Update:

It is a dell g5 gaming laptop 

Update 2:

I ended up returning it to best buy after trying everything your alls suggestions helped but it didn't in this situation but thank you anyway 

6 Answers

Relevance
  • 3 weeks ago
    Favorite Answer

    Probably because the movie and tv app created by MS is a piece of junk. It is not the PC, it is the app.

    That is why you can view the same video with different apps and it works fine.

    Change you default app to WMP or VLC and the problem is solved.

    Hopefully at some point MS will come out with a decent version of the program.

  • 3 weeks ago

    Download, the driver for the Nvidia Videocard that you use.

  • 3 weeks ago

    sounds like you've discovered a cheap app that should be replaced.

  • YKhan
    Lv 7
    3 weeks ago

    You would need to enable hardware acceleration in the video player app.

  • How do you think about the answers? You can sign in to vote the answer.
  • Dave
    Lv 7
    3 weeks ago

    The app is using your onboard video, not the dedicated video, which is pretty standard on any gaming laptop. More likely the software or the connection is garbage.

  • P
    Lv 7
    3 weeks ago

    Some apps are not capable of using the video card for decoding the video and may be slow.  Just change your default app.  

    • All video players I have restricts it to internal video memory only and won't let me change it to nvida 

Still have questions? Get your answers by asking now.