Cannot connect to devices behind switch after moving PC directly to gateway. please help!?

My setup before was:

Gateway > Lan1: Switch > All devices

I changed it to this setup due to accessibility:

Gateway > Lan 1: Server PC

Gateway > Lan 2: Switch > all other PCs

Now I cannot access all the PCs behind the switch. All the network settings are the same as when it was before switching to setup 2.

Please help.

2 Answers

Relevance
  • keerok
    Lv 7
    6 months ago

    I suspect everything is managed by DHCP? Your PC might be in a different network from the rest of your LAN. In other words, you might have 2 LANs. If you have 2 gateways, set the second as an access point from the 1st gateway. This will expand the reach of the first gateway.

    There is no need to separate your server from the rest of your network. If you are hosting sites in it to be accessed from outside your LAN, relegate your server to the DMZ address in your router's settings. If your LAN also need to access your server locally, install a second NIC to the server and set it up (Apache?) so that one would be for the WWW/DMZ and the other would be for LAN.

    • Sandra6 months agoReport

      I just found out that the gateway I have was set by the ISP to restrict the use of LAN 2 to 4. Though I was able to unlock it through the help of some guides online. It appears somehow that it is hardcoded for other services and it works just like a regular modem which LAN 1 serves as WAN port. :(

    • Login to reply the answers
  • Adrian
    Lv 7
    6 months ago

    What hardware is the "Gateway" ??

    If this is a regular router, then your second setup should work ok. If the gateway is some other device, like an ISPs modem, then you can only use one LAN port (possibility).

    Is the switch a managed switch? Does it allocate DHCP addresses?

    Not enough details about your actual hardware. If you specify models of the gear, we could maybe figure this out easier.

    • ...Show all comments
    • Sandra6 months agoReport

      I just found out that the gateway I have was set by the ISP to restrict the use of LAN 2 to 4. Though I was able to unlock it through the help of some guides online. It appears somehow that it is hardcoded for other services and it works just like a regular modem which LAN 1 serves as WAN port. :(

    • Login to reply the answers
Still have questions? Get your answers by asking now.