I recently bought a Minolta XG-7, however, after checking if everything was working (it was) suddenly the shutter stopped working...?

The film advance lever didn't seem to go all the way and after some fidgeting with the bottom screw i realized the shutter was stuck halfway across the frame, not allowing me to release it. Is there anyway to fix this? Do I need to recalibrate the gears underneath the camera? Thank you for your help in advance!!

Update:

Update: After further inspecting and research, I have tried to adjust the winder and idle gears however this has not helped at all. Is this worth a trip to a repair shop or do I just give up?

Attachment image

3 Answers

Relevance
  • Frank
    Lv 7
    5 months ago

    Repairs: $50-$100

    Buying a working model off of eBay: $35

  • qrk
    Lv 7
    5 months ago

    Long shot, try depress the take-up spool release button (it's a small button, about 3 or 4mm in diameter) which is usually located on the bottom of the camera on the take-up side of the camera.

    You can find one on ebay for less than it would cost to fix it. At this point, you can take the camera apart and see if something is amiss. If you break it, no big loss.

  • 5 months ago

    Stagg Field, at the University of Chicago, is where?

    • John P
      Lv 7
      5 months agoReport

      It is worth asking a repair shop for an opinion, and a price to fix it. That repair will probably not be cheap.

Still have questions? Get your answers by asking now.