2005 Altima misfiring problems?

AutoZone diagnostic said misfiring on cylinder 3, we got recommended coil pack for cylinder 3 and all new recommended spark plugs.

3 is still misfiring. Any ideas?

Update:

P.S. Sorry for not having been more specific. We did already put in the coil pack and plugs. It's as if they didn't do anything at all.

5 Answers

Relevance
  • Dan
    Lv 4
    6 months ago
    Favorite Answer

    First step is a compression test, if that's OK then a careful check for a vacuum leak at the #3 intake runner, then try swapping injectors with another hole and see if the misfire moves.

    • olive_r6 months agoReport

      Very much appreciate it.

    • Login to reply the answers
  • 6 months ago

    Replace plugs and coil pack. It could be other issues but plugs and coil pack are usually the issue. It's cheap enough.

    • Login to reply the answers
  • WB
    Lv 7
    6 months ago

    Check the injector, and the cylinder compression (you may have a leaking valve). Good luck.

    • olive_r6 months agoReport

      Very good answer, too. Thank you.

    • Login to reply the answers
  • 6 months ago

    Either keep throwing parts at it and crossing your fingers or go to the dealer.

    • Login to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • Gabe
    Lv 6
    6 months ago

    Sounds like the issue is that you have a misfiring on cylinder 3.

    • Dan
      Lv 4
      6 months agoReport

      Pure genius Gabe, how do you do that?

    • Login to reply the answers
Still have questions? Get your answers by asking now.