Why does my car radio not have any sound?

I have a 1999 Mercedes-Benz C280 with an aftermarket radio my brother put in. He lives 5 hours away and isn t answering his phone and I d like to get this figured out before I leave town. The radio turns on, changes stations and inputs and everything but there s no sound in the speakers. Any idea as to why? I tried to look it up on youtube but all i saw were actual installations. I was told I needed to buy a speaker and a speaker box to wire the radio to, and i did that. Now what?! help please!!

5 Answers

Relevance
  • 6 months ago

    It's definitely a speaker wirering issue.

  • 7 months ago

    The factory amp may be blown.

  • Phil M
    Lv 7
    7 months ago

    If the car has factory speakers there should be no reason to buy an external speaker box. I am going to guess that your brother cut the factory radio harness out of the vehicle and guessed at the colors of the speaker wires. If you're lucky, he only missed a ground wire or something simple. It could also be that the radio just quit working and needs to be replaced.

  • 7 months ago

    You have issues with the wires connecting your radio to the speakers.

  • How do you think about the answers? You can sign in to vote the answer.
  • 7 months ago

    clean some of the penis cheese out of it, the stuff naturally blocks sound when it gets stuck in there

    • Geo
      Lv 6
      7 months agoReport

      Nice Brother hooked it up and didn''t check that it worked?

Still have questions? Get your answers by asking now.