Since win 10 putting computer to sleep does not work. Screen comes back in 3 seconds. How do I fix this?

5 Answers

Relevance
  • 3 years ago
    Favorite Answer

    As "Possibly Correct" implied, there is probably a new driver installed with Windows 10 that is set to wake the computer. Open Device Manager and go through the settings of the various input devices such as mouse (or touchpad), and the network interfaces and make sure that none of them is enabled to wake the computer.

    Normally for network waking there should be a special so called "Magic packet" that wakes a computer. Some network adapters will wake the computer when they see any traffic. I used to have a desktop PC that would wake when it received any broadcast over Ethernet. Turning off the 'Wake on LAN' feature in the driver prevented that from happening.

    I recommend leaving the keyboard as a wake up device or you might find it is difficult to wake the PC once it goes to sleep.

    I hope this helps.

  • Lv 7
    3 years ago

    Windows 10 may not be compatible with your drivers. you need drivers that are compatible with Windows 10 for your motherboard/computer system. there may not be any, depending on your model...

  • 3 years ago

    Type "sleep" in the desktop search box. Click on power and sleep settings in the resulting search list. Go through each and every setting option and tailor it to your needs. Apply and save and exit.

  • 3 years ago

    I have no clue how to do that.

  • How do you think about the answers? You can sign in to vote the answer.
  • 3 years ago

    Figure out what driver or device is keeping your computer awake.

Still have questions? Get your answers by asking now.