Diagnosing/Replacing a bad TPS( Throttle position sensor ) .. Please help.?

Car-: Toyota Carina 210

I checked my TPS with a multimeter and it seems to be giving out bad voltage, when I increase the throttle it increases in some areas and decreases dramatically in some areas of the tps. Also the error code corresponds to the TPS sensor(41).

So now that I've established a bad tps, I went online to check for them and the model was nowhere to be found. Is it critical that I replace the current tps with the same model as before?

-Thank you!

4 Answers

Relevance
  • paul h
    Lv 7
    3 years ago
    Favorite Answer

    The 210 Carina model was only sold in Japan from 1996-2001 so you may need to find a parts source in Japan or an importer to get the correct part or sites that cater to Japanese market parts. The replacement part number may also differ from the numbers on the old TPS if it was upgraded since then. But the first set of numbers... 89452-20120....might be used to cross reference the new part. And yes, you should replace the TPS with the correct version for your specific year/model.

    Your diagnosis is also correct...erratic voltage readings as you open the throttle/TPS indicate it is bad and has worn or carboned up contacts inside the potentiometer which leads to stray or erratic voltage readings which in turn confuses the computer as to actual throttle angle for proper injector pulses, spark timing, etc... You might try cleaning the inside contacts with spray contact cleaner if possible by drilling a small hole near the contact areas and spray inside the unit and perform what is called " wiping the pot"....run the TPS through it's full range of motion quickly several times back and forth which might clean off any carbon tracks/buildup on the pot contacts and can often clear up erratic readings...a common trick used on audio pot's like volume controls that sound scratchy. Retest after cleaning/wiping the pot to see if readings improve.

    Also your error code 41 indicates an OBD-I system which would be early 96 or late 95 model which might confuse matters. 1996 and later used an OBD-II system with 4 digit trouble codes. What year is the car?

    https://www.amayama.com/en/genuine-catalogs/toyota...

    https://www.bestpartstore.co.uk/ersatzteile-suche?...

    • Gayal3 years agoReport

      You are correct, the car is a year 96 model so it uses OBD-I.
      Can't thank you enough for all the tips and advice on the issue, those links are a great reference for what parts I need to get( because the google searches I did turned up nothing useful).
      And again thanks a lot! Hats off to you sir!

  • 3 years ago

    Since you have no idea what you're doing let a mechanic diagnose your concern. You may have a bad TPS wiring connector or bad wiring problem or a TPS that is out of adjustment. You don't find that many bad TPS sensors to automatically just replace them with out further diagnoses.

    It's also best to test the TPS using an analog ohm meter with the TPS harness disconnected to make sure the sweep is smooth and un-interrupted.

    Source(s): Mitsubishi Master Tech
  • Anonymous
    3 years ago

    Of course it is. Try a parts store or dealership.

  • 3 years ago

    What I can see on the TPS sensor itself -:

    Toyota

    89452-20120

    198500-0070

    DENSO

    made in Japan

Still have questions? Get your answers by asking now.