Cannot fix a code in Java, problem with geometry class?

When I try to use javafx.geometry.Point2D always get this error
Access restriction: The type Point2D is not API (restriction on required
library C:\Program Files\Java\jre1.8.0_73\lib\ext\jfxrt.jar )
What s the problem? I am coding on Eclipse
1 answer 1