My iOS 5.1.1 will not let me download anything because I have to have an iPhone 6?

3 Answers

Relevance
  • Anonymous
    5 years ago

    You can only download apps that work with iOS versions up to 5.1.1. Newer apps that require iOS 7 or 8 will require a newer device capable of running the latest version of iOS.

  • 5 years ago

    A lot of apps now require iOS 7 or 8 to download them. The only way to get round it is to update your phone or, if your phone doesn't support iOS 7 buy a more up to date phone

  • Anonymous
    5 years ago

    iPhone 4s or above can run ios 8. If you cannot update your ios then you need a new device. Check for update via Settings>General>Software Update.

Still have questions? Get your answers by asking now.