My iOS 5.1.1 will not let me download anything because I have to have an iPhone 6?

3 answers 3