BlueStacks : Cant download app (error retrieving information from server)?

I'm on Windows 8

I had a crash this morning and BlueStacks stopped working.

Been using it since February with no problem.

I tried :

1- Microsoft System Restore (1 week earlier)

Results: still not working. Same problem: Star Wars Force Collection won't launch.

2- uninstalling/re install BlueStacks + Disk clean up

Results: I'm unable to download and install app Star Wars Force Collection.

I get Error message: app could not be downloaded do to an error. (Error retrieving information from server. [RPC:S-3])

Anyone can help with this?

Thanks

20 Answers

Relevance
  • pounds
    Lv 4
    4 years ago

    Google Play Wont Download Apps

  • 5 years ago

    First I couldn t download apps from play store due to the Can t download App" error and then when I tried some methods given above, it was going all right when my play store was only not opening... It was showing "Error while retrieving information"... I don t know what to do know

  • 6 years ago

    *SOLVED* This error is caused by the Google Play Services agreement not being accepted, this is not the fault of the user but a fault of Bluestacks missing the notification, here is the fix:

    Go to settings on your BS emulator, go to running apps and force stop all google services, then go to ALL apps and clear data/cache of google play, google services and google framework, force stop them, then finally restart Bluestacks, at some point, specifically when you open up the Play store, you should be met with a notification to accept terms and conditions, click to accept and then you will be able to install again without any issues.

    N.B. Please do not take messing around with your registry (regedit) on your computer as advice, unless you know what this is it is best to stay away as you can cause harm to your computer (software) by editing any of the values.

    Take care guys!

  • 6 years ago

    bluestacks : cant download app (error retrieving information from server)

  • How do you think about the answers? You can sign in to vote the answer.
  • 6 years ago

    First, Open CMD (Command Prompt) and type 'regedit' (no apostrophes), then a window will pop up and on the left-corner of the window, locate HKEYLOCALMACHINE, in its drop down menu look for "Software" and find Bluestacks and delete it. Then Install Bluestacks again. That will definitely work!

  • 6 years ago

    I'm having the same problem but with a windows 8. Does anybody have the answer to this prob?

  • 6 years ago

    Read this Article To Fix Bluestacks Failed To Connect To Server

    http://www.techpayee.com/bluestacks-failed-to-conn...

  • 6 years ago

    I finally resolved my problem.

    Found this on the web : http://forum.xda-developers.com/showthread.php?t=2...

    I tried many of the solutions explained and none worked but one :

    Go to settings > applications > Google Services Framework > Force Stop > clear DATA (it'll clear cache too)

    I was then able to install the app SWFC with no further problem.

  • Anonymous
    6 years ago

    why i use broadband to download clash of clans will appear error retrieving from server?

  • 6 years ago

    Please follow the below steps.

    Go to “Settings”

    Applications>Manage Applications >Select “All”

    Scroll to and tap Google Play Store >

    Force Stop > OK

    Clear data > and tap “OK”.

    Tap the Back button to get back to the applications list.

    Scroll to and tap > Google Service Framework

    Force Stop> OK

    Clear data > “OK”.

    Now reboot (switch on & off) your device.

    Thats it your bluestacks error is solved now.

Still have questions? Get your answers by asking now.