Ako keeps giving me a SSL Connection Error. How can I fix that?

So im logged onto AKO using my ID and password, not my CAC card. Im trying to access my clothing record under the self service tab. Once I get there and click on "Access Individual Clothing Record through AKO," I get a SSL Connection Error.

Here is the error details:

Unable to make a secure connection to the server. This may be a problem with the server, or it may be requiring a client authentication certificate that you don't have.

Error code: ERR_SSL_PROTOCOL_ERROR

Im using Google Chrome on a Windows Laptop. I have tried using Internet Explorer too, and still no luck.

Update:

Wraeth gave me good advice about installing the latest DOD Certificates, unfortunately still no luck despite having all the new certificates.

2 Answers

Relevance
  • Wraeth
    Lv 7
    7 years ago
    Favorite Answer

    www.militarycac.com

    ^Go there. Download the current certificates using the browser you wish to access AKO with.

    Be warned, logging into AKO now without a CAC will severely limit the functions you can do. You need CAC access to utilize all of AKO.

    Source(s): US Army Scout
    • Commenter avatarLogin to reply the answers
  • 4 years ago

    Ako Enterprise Email

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.