OMG, PLEASE help with Error retrieving information from server.[RPC:S-5:AEC-0] On my son's tablet?

Poor little guy just got this for his b-day and already can't use it. So irritating. I keep getting this error when try to download anything or update anything via Google Play:

Error retrieving information from server.[RPC:S-5:AEC-0]

I've tried backing up and restore, I've tried clearing the cache/data, moving apps to the SD card. I also read about clearing the data on the Android Framework. Well, I can't find that ANYWHERE on my phone and nothing seems to be doing the trick. I'm not well versed in Android, so please walk me though any fixes you might have. Thx

3 Answers

Relevance
  • 6 years ago
    Favorite Answer

    It actually depends on to your data service plan.. If u r using the 2g plans u must get those kinds of error.. Use the 3g plans or wifi.. I am sure u will not error while using 3g.

  • 6 years ago

    found this on you tube ....will include link

    This issue comes after the update of firmware from google to remove that

    1. Remove your google account from phone

    2. Goto settings, open apps

    3. Navigate to All apps

    4. Clear the data for the below mentioned processes Download Manager Google Play Store Google Services Framework

    You are good to go... open google play from your device and enjoy your download

  • Judith
    Lv 4
    4 years ago

    Hahaha Mt grandma always yused to sat people needed their mouths washing out.

Still have questions? Get your answers by asking now.