Samsung Galaxy S4 - Wifi Network disabled Internet slow?

I have a Samsung Galaxy S4 through Verizon. Over the weekend, I updated my phone with the new Android Jellybean software. Prior to this updated, I have always been able to connect to my office’s wifi with no issues. However after the updated, the phone will connect to the office wifi for a second or two, than return the following message, “Network Disabled because the Internet connection is slow” and cannot connect. I called my IT department, they said the office’s internet has not changed and I sit about 50 feet from the wifi router. Now I do get wifi connection at home and other places, and considering that the only change since last Friday was from the software updated, it has to be a phone issue.

I have done the following to get the wifi to connect:

Have “removed” the network and reconnect to wifi (no luck)

Done a complete shut down and reboot of the phone (no luck)

Taken the phone into Samsung (in Best Buy) and had them run a check to make sure the software is installed correctly (and it is)

Gone to Verizon store and had them look at it (they found no issues)

What else can I do? I enjoy using apps the need a connection (ie Pandora, Facebook), but just do not want to waste my data plan while at the office.

17 Answers

Relevance
  • 6 years ago
    Favorite Answer

    Check the wifi setting then go to advanced setting and uncheck the "Auto network switch" dialog box. Then Thats it. That's my problem too when i updated my samsung s4 for Jelly Bean 4.3.I hope i helped you in this little issue. God Bless! :)

    • ...Show all comments
    • 6 years agoReport

      Ryan - You are the BEST!! I have searched for HOURS and HOURS and this did the trick immediately - without rebooting the phone or anything. I was having this problem ONLY at work as well.... Wish I had found your answer before. thank you! tahnk you! THANK YOU!!

    • Login to reply the answers
  • kardos
    Lv 4
    3 years ago

    Samsung Galaxy S4 Issues

    • Login to reply the answers
  • Lisa
    Lv 4
    4 years ago

    A possible fix here 7/5/2014.... One thing to try here that helped me "believe it or not" was uninstalling AD-Block Plus. Everyone was saying it was the best Ad blocking app out there so I installed it. But I found that it did not block those pesky banner ads at the bottom of my S4 screen that were driving me nuts. That is when I began to notice the starting of the problems listed here to my WIFI and tried most everything from updating firmware to restarting Samsung S4 to..... Then I backed tracked what I had done ij installing apps being a programmer and I uninstalled ABP and now my Samsung Galaxy S4 WIFI is working fine. Try it and see. It could not hurt. By the way, AdFree app and rooting stopped those pesky banner ads. Hope this helps.

    • Login to reply the answers
  • Anonymous
    6 years ago

    I have done what Ryan stated, which is fine, but the Auto network switch keeps turning back on when I uncheck it. I think it may be happening when the phone sleeps. How do I get it to stay unchecked? This is really ticking me off. It used to work great until I used my S4's mirror imaging with Netgear's Push2TV. Now I constantly get the message that my wifi is unstable both at home and at school.

  • How do you think about the answers? You can sign in to vote the answer.
  • Anonymous
    6 years ago

    hey everyone.. i recently had this issue on my samsung galaxy s4 and i searched all over and found a fix for me.. i dont even have to take off the auto network switch.

    Step 1 Go to the home screen on your phone.

    Step 2 Select the telephone dial pad.

    Step 3 Dial *#0011#

    Step 4 Press the settings button on phone and select wifi.

    Step 5 You should see the safe wifi button on so just press it so it turns off.

    The phone comes with these features to save battery so if it finds that the connection is disabled by its standards then it just automatically shut off. This will allow you to override. This should fix your problem if it doesnt also then go to the wifi advanced settings and turn off the automatic network switch. Mine got fixed by disabling the safe mode only.

    hope this helps my fellow android lovers!

    • ?5 years agoReport

      Thanks for the help. I've looked every where and this solution has worked all up an running WiFi and Bluetooh.

    • Login to reply the answers
  • Anonymous
    6 years ago

    Only For Samsung

    Step 1:

    Turn off the wifi and go to ‘Allshare’ feature of Samsung Android phones.

    Step 2:

    When it asks you to connect to a wifi network, just connect to the one you want to.

    It magically removes the issue but this fix only works because of the Allshare feature so its limited to only Samsung Android phones.

    For more information visit

    http://www.solveinweb.com/android-wi-fi-error-wi-f...

    • Login to reply the answers
  • 6 years ago

    Thank you! I was having the same problem with my Verizon Samsung Galaxy S3 after the OS upgrade. It's working now.

    • Login to reply the answers
  • Anonymous
    6 years ago

    i have a galaxy s4 gt i9500 unlocked version!!

    please help me i am having the same problem!!

    it shows that wifi connection is unstable. this problem is going on after the 4.3 update on my home network.

    the wifi is working fine on other devices but not on my galaxy s4.!

    i have disabled the auto switch option but the problem is still there.

    • Login to reply the answers
  • Anonymous
    6 years ago

    Thank you Ryan.. You are the best.. I had the same problem on my Verizon S4 right after the update ..

    I just followed your advice.. and voilà.. it worked..

    THUMBS UP :-)

    • Login to reply the answers
  • 6 years ago

    Goto wifi settings uncheck the box that says "Auto Switch Network"

    This worked for me

    • Login to reply the answers
Still have questions? Get your answers by asking now.