No browser access to the internet although other web services work?

My brower stops being able to access the internet, i get the warning "this webpage is not available" (for all searches) but other web services such as spotify and remote desktop continue to work (only if already started). Has anyone got any idea what is causing this as it is very annoying. For information I can connected to the net via LAN in an office building and other people are not getting the same problem.

Update:

Need to make it clear that I have tried all browsers and there appears nothing wrong with the internet connection as every other terminal in the office is working. The computer is accessing the internet because it is staying connected to remote desktop, however, when the browser gives me the warning "this webpage is not available" I cannot start any new web tools such as RDP / spotify, but if they are already running then they continue to work.

1 Answer

Relevance
  • 8 years ago
    Favorite Answer

    You could try using a different browser such as Google Chrome or Internet explorer... if that doesn't help, make sure all the wires on your router are correctly plugged in and pushed in tightly and if they are and it's still not working I would call the company you get your internet from.

Still have questions? Get your answers by asking now.