It's a mess connecting to wifi.?

Im having trouble getting proper wifi speed.

This is big.

I recently assembled a pretty respectable desktop. II won't list all the specs just the relative ones. The motherboard is an ASRock z77 extreme 4, the wifi adapter is a PCE-N10 Wireless N 150Mbps PCIe Adapter and there is another wireless adapter in the USB 3.0 in the front a TpLink TL-WN727N. Im also dual-booting Win7 and Ubuntu 12.04 LTS (x64)

So my assumption is that the wifi adapters and the computer and the router arent really playing well together. I should mention im using my neighbors wifi until i pay my cable bill

When Im booted into Windows 7 both adapters would be able to link with the wifi network except the data speed is incredibly slow..pings take like 500ms, data speed was definately around 100kbps. So installed Ubuntu on a seperate partition. Now booted into Ubuntu the Wifi adapter card has a similar link problem how ever the USB tp link card is going prtty fast (speednet.com says 8ms ping and aroudn 4Mbps) Normally I would solely rely on Ubuntu how ever afew programs I use are still within 7.

Now it isnt a reception issue the computer all report a good connection and other wifi devices in the same room (like my android phone connect pretty well) also ti be mentioend i had this problem with an old laptop of mine(HP Dv4). I used the same TP-Link adapter and connection speeds were really slow in Vista and win 8.

I should also mention some extra software was included when i sintalled the cds like for example this xfast LAN program which im guessing might be in the way that came with the Motherboard CD.

I look foward to responces thanks guys.

Update:

I changed the duplex settings and nothing. Thanks for your suggestion though.

2 Answers

Relevance
  • 7 years ago
    Favorite Answer

    Often this problem revolves around the software configurations via the device itself.

    Begin by opening control panel, go to internet connection settings "Network Connections", right click your Local Area Connection, saying this i am under the assumption that you also have a LAN, as a wireless connection requires a modem which is either working with a router, or is also a router built in.

    Right click "Local Area Connection" and go to properties, on the very top your device should automatically be recognized above "Client for Microsoft Networks".

    Click "Configure", and proceed to the advanced tab.

    Click "Speed & Duplex", and change it from auto configuration to "100mbps Full Duplex".

    This should have an impact on the availability of said bandwidth on a wireless configuration as well.

    Also, reset both device or power them off for one minute each, if this is necessary.

    • Login to reply the answers
  • 3 years ago

    The WEP secret's within the router. Find the Default Gateway from a computer the is wired to the router. Click begin Run and variety cmd then hit enter. In an effort to carry up a command prompt. Then kind ipconfig /all and hit enter. You're going to get A list of the community IPs. Look for the Default Gateway 192.168.1.1 . Sort that quantity into you internet browser. For a Linksys router the username and password is admin click on on the wireless tab. Then click on the wireless security tab. There you're going to find the WEP key.

    • Login to reply the answers
Still have questions? Get your answers by asking now.