Error Retrieving Information from Server. [RPC:S-5:AEC-0] Google Play?

I can't download anything from Google Play anymore. Apparently this has become a problem for many recently.

I cleared the data and cache.

Forced stop.

Uninstalled updates.

Switched accounts.

Restarted phone.

Removed accounts then re added them.

NONE OF THESES THINGS HAVE WORKED! >:(

Also my phone has not been rooted.

I am guessing I might need to do a factory reset to fix it. Any ideas?

Thank you in advance

9 Answers

Relevance
  • 7 years ago
    Favorite Answer

    Google Play Error [RPC:S-5:AEC-0]

    i am getting same message when trying to install apps on my smart phone today. Just talked to Google play chat person and HE SAID IT WAS A PROBLEM WITH GOOGLE PLAY THAT THEY WERE TRYING TO FIX ON THEIR END... so i can stop messing with my phone (my words) and get on with my day! Hopefully they will fix it today! Cause I uninstalled my phone's clock and i miss it!

    Source(s): google play chat service/call back.
  • Anonymous
    7 years ago

    I was having the same problem with mine tonight but just started working again now! I cleared data and cache but that didnt help. I was going to factory reset but just tried to download one last time and thankfully it was working fine again so i think its just a maintenence problem! Hope yours is also back to normal soon!

  • Anonymous
    7 years ago

    I bought a Xoom tablet yesterday and the same is happening. I even factory restored it!

    Source(s): My Xoom.
  • Anonymous
    7 years ago

    I just had this problem. Clear you cache form the Google Play app and you'll be ok. At least that worked for me.

  • How do you think about the answers? You can sign in to vote the answer.
  • 7 years ago

    I, too, am having issues. :( Strangely, the ID for the Kindle Fire (rooted) has changed to "Kindle%20Fire

    ". Perhaps it's going under maintenance or something...

    EDIT: It's working again! :) I just successfully installed "GYRO" to test it.

    Source(s): Rooted 2nd Gen Kindle Fire
  • 7 years ago

    Mine is also doing the same thing

  • JK
    Lv 4
    7 years ago

    I'm having the same problem. It seems to be a big google play store problem. They should fix it soon.

  • 7 years ago

    Back up all your stuff through Kies Air.. then do the factory reset.

  • 3 years ago

    I 2 have an ace. Gooogle play works of gmail, i introduced games on my ace, then my bro had 1. So i put my gmail account on his mobile so he could get those games totally free. Equal with my tab 7.Zero. So to dload stuff on Play store you need to have your gmail account on your mobile!

Still have questions? Get your answers by asking now.