Computer Shuts Down Sims 3?

Okay, I have a major problem with Sims 3. I start Sims 3 (with Showtime and Seasons) and when I try to create a sim it shuts down after couple of min. It worked fine on the laptop before...

So this is what I have tried to do:

*I have bought Cooling Pad - Coolmaster Notepal U3 (will recieve tomorrow)

*Changed "Screen Refresh Rate" in the game ( I read it on another forum) instead of downloading a ftps limiter because I play the game in fullscreen. the game still shuts down :-( ...

* Tried to reinstall, unistall and all that... not working still...

*Tried to use speedfan so I can control change the fan speed but the motherboard is not supported! I have noticed that in speedfan the Temp1 is always high but there is no sound from the fan and also the other numbers are high but no sound from the fans and the computer is not warm...

So my q is, is there anything more I can do WITHOUT being to risky like overclocking and all that...

Thanks.

Update:

Don't know how to answer you so I did like additional Details, but the specs are:

Aspire 5739G

Intel Core Duo CPU P8700 2,53GHz

RAM 4.0 GB

GeForce GT240M CUDA 1GB

Update 2:

Here is when I have played sims 3 in couple of min - speedfan:

http://oi47.tinypic.com/15sagdd.jpg

I think the temps are ok? I have searched and I found out there are many that have 80C or 70C...

Update 3:

I have read some to about v sync or what it's called, I have changed to "force on" for my Nvidia graphic card, also made a ftps limiter - 30 fps as a max.. What I can see directly is that the laptop is not warm and that sound so much.. Will try out and see how the game works..

3 Answers

Relevance
  • 4 years ago

    Appears like a RAM problems with me, your computer generally has just adequate Ram to run Sims 3 without expansions, but as quickly as you load expansions you could have taken up your entire Ram.. And most of the time when all RAM is taken up your computer can shut down or crash. You must upgrade your RAM to as a minimum 2GB

  • Anonymous
    8 years ago

    Try this: go into Options and under the graphics settings turn off the advanced rendering selection. Also, go into your display settings on your computer/laptop and set your graphics options to favor performance. You can always adjust this to your liking, but this does not affect gaming graphics, only those on the desktop

    Source(s): personal experience, though on a different type of computer.
  • John
    Lv 7
    8 years ago

    first off,need to know what processor and graphics you have. contact me with that info and i can help you.

Still have questions? Get your answers by asking now.