Help, my speed dial master lock won't unlock out of its packaging!?

Today I went to Staples and bought a Speed Dial MasterLock [the one that you open by sliding the thing in a combination of ups, downs, lefts, and/or rights] for my gym locker. I opened the bottom part of the packaging that has papers with the preset combination. I followed the instructions, clearing the lock by pressing/squeezing 2 times and then proceeded to do the preset combination. It didn't open and I tried this another 100 times. It still won't open.

Sorry if the category is irrelevant, Yahoo doesn't have anything else that's even as close to master locks :(

4 Answers

Relevance
  • 8 years ago
    Favorite Answer

    i did the same thing,only thing i could think of is someone had it bfore you,and played with it,bfore reading instructions,i took mine back,and got one with key,love it lol

    • Login to reply the answers
  • 5 years ago

    Well, I had one for about 5 months that worked fine until yesterday. Suddenly, out of the blue, it won't take the combination anymore. I would not recommend this lock!

    • Login to reply the answers
  • Anonymous
    8 years ago

    Please double check the preset combination. Mine was up down right up but due to habit I kept doing up down right left!!!

    After I finally figured out the correct combination I have not had an issue with this lock! I love it, not going back to keyed locks!

    Source(s): Personal experience!
    • Login to reply the answers
  • 4 years ago

    I had the same problem. I tried up down right down and it worked although the preset in the instructions said something else. Keep trying and it might work for you.

    • Login to reply the answers
Still have questions? Get your answers by asking now.