Yahoo Answers is shutting down on May 4th, 2021 (Eastern Time) and the Yahoo Answers website is now in read-only mode. There will be no changes to other Yahoo properties or services, or your Yahoo account. You can find more information about the Yahoo Answers shutdown and how to download your data on this help page.

Why is it that sites will say that I need an updated browser when i just updated to internet explorer 9?

I can't even play that cut the rope game!

2 Answers

Relevance
  • 9 years ago
    Favorite Answer

    It sounds like an IE 9 glitch.

    I have had the same problems; but, there is a site you can use to play the game

    Below the green bar that has Play Cut The Rope

    click on the IE9 link right below.

    Works for me.

    http://jayisgames.com/archives/2012/01/cut_the_rop...

    Source(s): You might want to try Mozilla Firefox browser.
  • Anonymous
    9 years ago

    Which sites?

    Are you using IE9 to visit the sites? or you have IE9 installed but use other browser to visit the sites?

    As I know, IE9 has the compatible view. make sure you are not in IE compatible view, if you use browsers like Avant browser, there is a IE compatible engine, if you use this engine. it will be recognized as an old version.

Still have questions? Get your answers by asking now.