Yahoo Answers is shutting down on May 4th, 2021 (Eastern Time) and beginning April 20th, 2021 (Eastern Time) the Yahoo Answers website will be in read-only mode. There will be no changes to other Yahoo properties or services, or your Yahoo account. You can find more information about the Yahoo Answers shutdown and how to download your data on this help page.

1975 corvette running hot have changed rad. water pump and put in bars leak still runs hot.?

5 Answers

Relevance
  • 9 years ago
    Favorite Answer

    Hi, It sounds as though you may have clogged water ways? especially if you have put barrs in as well, Try flushing the system thoroughly with a hosepipe (see if any sediment comes out) if there is debris in the flushed water keep flushing untill it runs clean, Then put a flushing agent in the system top it up to the correct level, run the engine upto itsoperating temperature & flush it again? (You may need to flush it a few times to clear the blocked waterways)??

    Hope this helps

    Leigh

  • John
    Lv 7
    9 years ago

    Have you checked the thermostat? The fan? Gotten all the air out after putting in the new radiator?

  • Pete M
    Lv 7
    9 years ago

    Sounds like you may have air in your cooling system. This will not permit the coolant to circulate and must be purged before the water pump can pick it up and circulate it though the system.

  • Bob H
    Lv 7
    9 years ago

    Dollars to donuts, you have a clogged exhaust. Probably the baffles in one muffler have collapsed. Even before you look at that; look on the exhaust manifold heat riser. you have to be able to move it very easily. If not, just soak it with penetrating oil and GENTLY tap it back and forth w/ a hammer.

  • How do you think about the answers? You can sign in to vote the answer.
  • 9 years ago

    Why did you put bars leak in the radiator if it's new and not leaking?

    Source(s): Service adviser
Still have questions? Get your answers by asking now.