gta 4 pc graphic problem?

pc specs:

intel i7 2.2GHz (3.10 turbo) 8 cores

6gb of ram

nvidia geforce gt555m 2gb

so when i start the game the graphics are f-upped and most of the city is transparent. when i go on graphics menu it says that i don't have enough memory on my graphic card and that i have only 52 mb instead of the 2gb i actually have on it. i can play fu*king battlefield 3, skyrim and assassins creed revelations all on high settings and these are all recent games, but when it comes to a 5 year old game it fu*ks up. WHAT MUST I DO. CAN THIS BE FIXED????

4 Answers

Relevance
  • 8 years ago
    Favorite Answer

    yes it can be.

    ust had a thought about this and in theory it should work

    Step 1) Open Steam Games List

    Step 2) Right Click GTA IV and select 'Properties'

    Step 3) Select 'Launch Options'

    from there you can use the command lines to tweak the game

    Ive got the retail version myself, and i use the following command lines

    -width 1280 -height 1024 -shadowdensity 0 -viewdistance 10 -texturequality 0 -renderquality 0 -detailquality 10 -nomemrestrict

    the full list of command lines are listen below

    Quote:

    Tools:

    -benchmark: Runs the benchmark tool and immediately exits game.

    -help: Display list of all command line options

    Graphics:

    -renderquality: Set the render quality of the game. (0-4)

    -shadowdensity: Set the shadow density of the game. (0-16)

    -texturequality: Set the texture quality of the game. (0-2)

    -viewdistance: Set the view distance of the game (0-99)

    -detailquality: Set the detail quality of the game. (0-99)

    -novblank: Disable wait for vblank (No Vsync)

    -norestrictions: Do not limit graphics settings

    -width: Set width of main render window (default is 800)

    -height: Set height of main render window (default is 600)

    -safemode: Run the graphics in the lowest setting possible

    -frameLimit: Limit frame to interval of refresh rate

    (ex If refreshrate is 60HZ –frameLimit 1 = Locks down to 60HZ)

    -refreshrate: Set the refresh rate of main render window

    – Warning - Monitor must support (ex. –refreshrate 60)

    -fullscreen: Force fullscreen mode

    -windowed: Force windowed mode

    -availablevidmem: Set amount of physical Video Memory(ex. –availablevidmem 0.9)

    -percentvidmem: Percentage of video memory to make available to GTA

    Audio:

    -fullspecaudio: Force high-end CPU audio footprint

    -minspecaudio: Force low-end CPU audio footprint

    System:

    -noprecache: Disable precache of resources

    -nomemrestrict: Disable memory restrictions

    • Login to reply the answers
  • 3 years ago

    Gta 4 Graphics Fix

    • Login to reply the answers
  • Anonymous
    5 years ago

    RE:

    gta 4 pc graphic problem?

    pc specs:

    intel i7 2.2GHz (3.10 turbo) 8 cores

    6gb of ram

    nvidia geforce gt555m 2gb

    so when i start the game the graphics are f-upped and most of the city is transparent. when i go on graphics menu it says that i don't have enough memory on my graphic card and that i have only 52 mb...

    Source(s): gta 4 pc graphic problem: https://trimurl.im/j92/gta-4-pc-graphic-problem
    • Login to reply the answers
  • This worked for my. Try it:

    1. Right click on your GTA IV shortcut and select properties

    2. In the TARGET portion, after the last quotation mark, add 1 space and type this: -norestrictions

    3. Click apply and click continue if it asks for adminitrator rights.

    • Login to reply the answers
Still have questions? Get your answers by asking now.