promotion image of download ymail app
Promoted

Black Screen During Installation of Ubuntu help?

So here's the deal, i install ubuntu 11.10 alongside windows blah blah, well when i restart my computer and choose to run ubuntu, it says finishing installation.... or whatever and then the backlight to my laptop goes off, making it black of course, and then thats it. Remains that way forever! I've tried all the avaiable options of running ubuntu, like the graphics safe mode, verbose, all of that, does no good. I've also reinstalled several times from hard disc, virtual drive (mounting the .iso image), installing off usb, and simply running off usb. Also, i've tried both running and installing from an actually live disk of Ubuntu 10.04. I figure Ubuntu has a real problem with my graphics card, but surely there is a fix right? My specs follow..thanks for your help in advance!

------------------

System Information

------------------

Time of this report: 12/4/2011, 16:12:48

Machine name: BRADS-HP

Operating System: Windows 7 Home Premium 64-bit (6.1, Build 7601) Service Pack 1

Language: English (Regional Setting: English)

System Manufacturer: Hewlett-Packard

System Model: HP Pavilion g7 Notebook PC

BIOS: InsydeH2O Version CCB.03.61.22F.33

Processor: AMD A4-3300M APU with Radeon(tm) HD Graphics (2 CPUs), ~1.9GHz

Memory: 4096MB RAM

Available OS Memory: 3562MB RAM

Page File: 1732MB used, 5391MB available

Windows Dir: C:\Windows

DirectX Version: DirectX 11

DX Setup Parameters: Not found

User DPI Setting: Using System DPI

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

DxDiag Version: 6.01.7601.17514 32bit Unicode

---------------

Display Devices

---------------

Card name: AMD Radeon(TM) HD 6480G

Manufacturer: Advanced Micro Devices, Inc.

Chip type: ATI display adapter (0x9648)

DAC type: Internal DAC(400MHz)

Device Key: Enum\PCI\VEN_1002&DEV_9648&SUBSYS_3568103C&REV_00

Display Memory: 2022 MB

Dedicated Memory: 497 MB

Shared Memory: 1525 MB

Current Mode: 1600 x 900 (32 bit) (60Hz)

Monitor Name: Generic PnP Monitor

Monitor Model: unknown

Monitor Id: LGD027A

Native Mode: 1600 x 900(p) (60.080Hz)

Output Type: Internal

Update:

It's not the brightness because the screen actually shuts off, you can tell that the backlight has turned off, but I went ahead and tried the method listed in answer #2 and it still didn't work. I did notice however that when it's listing what's happening before the monitor shuts off it kinda pauses on "ignoring bios query" then continues displaying the boot junk until the screen goes off shortly after. Of course it's going to fast to read too much.

Update 2:

And not that it really matters but I updated to windows ultimate

2 Answers

Relevance
  • UID.0
    Lv 6
    8 years ago
    Favorite Answer

    Sounds like it may be a BIOS related issue or a Driver issue. I'm leaning towards a Driver, first.

    To save yourself a tone of trouble with drivers, try a Live DVD of "Ultimate Edition (UE)". It is Ubuntu but the author has pre-packed it with a ton of drivers, wireless support for laptops etc. Version 2.8 or 2.9 might work for you.

    Ubuntu 11.10 is does not have all the kinks worked out just yet so maybe give that UE a shot since your options are more open.

    http://ultimateedition.info/ultimate-edition/ultim...

    http://ultimateedition.info/

    • Commenter avatarLogin to reply the answers
  • 8 years ago

    I've seen a few HP machines with this, and it's was a BIOS bug. The default monitor brightness is set at 0 in one of the acpi tables. If the increase brightness hotkeys don't work try booting without acpi. (append "noacpi" to end of the kernel= line in grub. Either way should let you change the default in the settings/power menu.

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.