Steam language help!!!?

Help please!! My steam account language suddenly changed to russian! And so are some steam games and I can't turn it back! It's driving me nuts I don't know what I'm clicking. Help please, how do I change it back? T_T I think it was because of the counter strike I installed? I uninstalled it but nothing happened. Help please, does anyone know how to change it back to english?

2 Answers

Relevance
  • 10 years ago
    Favorite Answer

    1. Right click the Steam icon in the icon tray (usually the lower right corner of your desktop screen).

    2. A rectangular box should appear giving you options of what you want to do. Starting at the bottom of the rectangular box should be the EXIT option which is separated by a line from the other options. Above the EXIT option is the option for FRIENDS. Above the FRIENDS options is the option for SETTINGS. Click the SETTINGS option and a window should appear with your Steam account username and Email address at the top of the window along with many tabs which you can select from.

    3. Go to the third tab from the left in the SETTINGS window.

    4. The third tab will have three rectangular boxes with arrows pointing down which you can click and the box will drop down with more options to select from.

    5. Click the FIRST rectangular box at the top of the window.

    6. Find ENGLISH (ENGLISH is in English in the drop down box) and click it.

    7. Click OK at the bottom of the window screen.

    8. A new window will appear giving you two options. Click the option on the the left.

    If you follow my directions then you should be successful in changing your Steam language back to English. Good luck!

  • 7 years ago

    Thanks for the answer dude ;-)

Still have questions? Get your answers by asking now.