my keyboard types numbers instead of letters?

My Dell keyboard is typing letters instead of numbers...It will type fine as you see but on Minecraft it will be a randomly linked number as I used WASD to move or T to chat and on Realm of the mad god if I hit W to move my character will continue moving and never stop and its not just WASD its every key on my keyboard it does a number on every game I play I googled it and saw that I might have toggled something to make it switch roles but It didn't work even with a switched out new keyboard it still won't work...How can I fix this problem?

2 Answers

Relevance
  • 8 years ago
    Best Answer

    okay, so i found this answer posted by someone else on another yahoo answer.. This might be the case why:

    If you've recently downloaded an Anti-Virus (I downloaded Constant Guard by Comcast) it might be the culprit.

    For my problem. Constant Guard had "Key Protection" on, which with that it downloaded something called GuardedID. But in the end all i had to do is uninstall the program from Comcast, restarted my laptop, and it was fixed. (GuardedID uninstalls when you uninstall Constant Guard.)

    I hope this helps and isnt too confusing.

    Source(s):

    Happend to me yesterday after someone downloaded Constant Guard on my laptop

  • Anonymous
    8 years ago

    Are you using a laptop? You might have switched on the Num Lock function.

    Try searching for the Num Lock function on your keyboard.

    Hold the Fn (this is usually beside the Left Ctrl and The Windows Logo) and then the Num Lock function (this will probably be placed somewhere in the upper right part of your function keys).

    After it has been turned off, your computer is back to using all the letters.

Still have questions? Get your answers by asking now.