Why do I have to battle with Yahoo to keep Google as my default search engine?

Yahoo the amount of time it takes & the constant battle for the default search engine to remain Google based for for Firefox. Get it right yahoo with your options of information within your search engines ability.

It seems that more consideration is put into Google's first page that you go to, while surfing the net.

6 Answers

Relevance
  • 10 years ago
    Favorite Answer

    on your PC, you should be asked to define your default search engine, (Yahoo, Google)you just need to choose one and then check the box as your default search engine. You may need to go into properties and assign the URL there also.

  • 10 years ago

    It shouldn't be a constant battle; are you usIng a yahoo toolbar or something? You shouldn't get asked all the time....

    Now, the iPhone is another issue. Any time I click anything on yahoo (well, weather, for example) it asks to change my default search to yahoo. Kind of annoying.

  • 6 years ago

    uninstall "search protection" by Spigot. If that is installed then this will fix it.

    Then, just to be sure you never have to use Yahoo search ever again, remove all references to yahoo from your list of search engines in your browser settings.

    I wish I could say this is shocking behaviour by Yahoo but I'm not in the least bit surprised

  • Anonymous
    10 years ago

    If you're using Firefox go here and it will tell you how to set Google as search engine and keep it that way. You're doing something wrong:http://www.google.com/support/websearch/bin/static...

  • How do you think about the answers? You can sign in to vote the answer.
  • 6 years ago

    now i have yahooie as my default. i changed it, deleted it, it came back. i cannot get rid of it. i don't want it, never ordered or okay'd it and it is here no matter what. what did i download that took over? what devious methods do you use to install this crap on my pc? how can i rid myself once and for all ???

  • Anonymous
    5 years ago

    have you downloaded the yahoo toolbar? if not check if yahoo is your default home page. This should not happen.

Still have questions? Get your answers by asking now.