Why is my keyboard typing numbers instead of letters?

I am using a desktop computer. For some applications, including my email program and some gaming programs, my computer thinks that I am typing in numbers, when I am actually typing in letters. For example, when I press "a," it shows up as a 1. Then, when I press another letter, it shows up as a 2, and it does that for every letter that I type. When I type a letter, the computer will type in the numbers 0-9. This means that when I type in "gaming," for example, it will show up as 123456. I tried using several different PS/2 and USB keyboards, but the problem is not going away. What can I do to fix this problem?

13 Answers

Relevance
  • Anonymous
    9 years ago
    Best Answer

    Hey, i see all these people saying "Num lock is " or press certain keys, but no, it's nothing about that.

    If you've recently downloaded an Anti-Virus (I downloaded Constant Guard by Comcast) it might be the culprit.

    For my problem. Constant Guard had "Key Protection" on, which with that it downloaded something called GuardedID. But in the end all i had to do is uninstall the program from Comcast, restarted my laptop, and it was fixed. (GuardedID uninstalls when you uninstall Constant Guard.)

    I hope this helps and isnt too confusing.

    Source(s): Happend to me yesterday after someone downloaded Constant Guard on my laptop.
  • 4 years ago

    This Site Might Help You.

    RE:

    Why is my keyboard typing numbers instead of letters?

    I am using a desktop computer. For some applications, including my email program and some gaming programs, my computer thinks that I am typing in numbers, when I am actually typing in letters. For example, when I press "a," it shows up as a 1. Then, when I press another letter, it shows...

    Source(s): keyboard typing numbers letters: https://shortly.im/XAq7p
  • 9 years ago

    Wow, just wanted to say thanks to Jesus Iam, you were 100% right. I was having the same issue as the poster, and I knew it wasn't a numlock issue, but couldn't figure out what was going on. Would only have issues with some programs, like yahoo messenger or shockwave games, while everything else worked. As soon as I got rid of the Comcast security stuff and rebooted everything was fixed. Cool, thanks again

    Here's some info,if anyone's interested, I guess it's a pretty common problem with the Comcast software, but I had no idea until I read the posts.

  • 187
    Lv 6
    9 years ago

    Yeah, I've had this happen to me on my laptop

    Try this.

    Press the Start key + R.

    type osk in that box and hit enter

    On this keyboard, try toggling numlock scrolllock and capslock a few times.

    Also, try this too: Fn+Numlk or depending of the model, press the button or Fn + Shift +Numlk

    Source(s): ccna
    • Timindu5 years agoReport

      This usually fixes old computers like mine, an old Vaio running windows xp. Thanks alot!!

  • How do you think about the answers? You can sign in to vote the answer.
  • 4 years ago

    For the best answers, search on this site https://shorturl.im/axeR9

    in the game itself look at options and map your keyboard you can do it from control panel as well look for joystick settings good luck i'll check back here later if you need to edit your Q

  • 6 years ago

    cool down guys its not the virus nor any hack let me explain the case,

    when u connected any external usb keyboard to your laptop and if you press num lock key on the extenal keyborad it'll start behaving like this as no num lock key presents on ur laptop so to avoid this connect ur usb keyboard again and just press the numlock button then enjoy the typing thank u

    • irenem285 years agoReport

      this is the exact solution to the problem. I have an external wireless keyboard and pressed the num lock in the external keyboard. when I removed the external keyboard and used the laptop keys, the characters were different. I went back to the external keyboard and disabled the num lock key.

  • Anonymous
    4 years ago
  • 6 years ago

    HIT Fn and ScrlLk keys

  • 9 years ago

    I forgot the key combination but if u press alt+pause break, that will help. Not sure.

  • 6 years ago

    it is the number lock we had the same problem and just solved it

Still have questions? Get your answers by asking now.