Yahoo messenger - Text disappears once I type in the text and press enter. Nothing visible in chat window!?

Once I type in text and press enter in chat window, it does not appear. Nothing is visible in the chat window. Though the notification in the task bar, if enabled, does show the message notifications.

Source of the problem :

I had run Safer Networking's

Safealyzer and Runalyzer, and blocked some running programs. I usually block programs without any signature. But not sure in this case.

In the process somethings got blocked. As a result I now get - "Some ActiveX controls are blocked"

everytime I start my system.

Solutions tried :

I thought I had found the answers whenever I encountered these, but these did not solve my problem

1. Installing various players/scripts

http://answers.yahoo.com/question/index?qid=201007...

2. Enabling all possible options in ActiveX controls in internet explorer - security

3. Going to manage add ons, and enabling everything I could recognize, including yahoo.

4. Going to msconfig, and enabling everything in 'startup' tab.

Solution Tried :

Chatted with online yahoo customer care, and they were unable to solve the problem after having to install the latest version of IE, yahoo messenger and java.

My question is :

I am pretty sure, this is because an activeX control has been blocked. How to find out which activeX was blocked, and enable it?

Update:

I am on windows XP

Update 2:

@reizaal - I did not find so many zones. I found three files in the registry at your suggested location - default, selfheal, securitysafe.

I dont think I have a virus. I think I have by mistake disabled an activex control.

6 Answers

Relevance
  • 9 years ago
    Favorite Answer

    You managed to chat with customer care, congratulation! :)

    anyway have you tried this solution? try fix by deleting the extra zone in registry (navigate to HKEY_CURRENT_USER > Software > Microsoft > Windows > CurrentVersion > Internet Settings > Zones and delete extra keys/zones other than 0,1,2,3,4) it's a good thing kill that virus too. try fix it with commercial antivirus if you have one, then fix the registry key.

    If you don't have commercial antivirus or they failed, try to locate the virus files (i use free PrevxCSI that show where the file is), then use AnVir task manager to pause, then kill the process, after that, run cmd command as an administrator, locate the directory and delete the file. (i keep prevx run all the time, it's light and super fast, virus pattern stored on their online server - latest, tiny footprint on my pc, i just need to monitor the virus coz i can clean/hack it manually)

    That enabling script in IE zones is the previous solution for different virus (2-3 years ago). this time around they created a stealth zone, and their coding disabled the script functionality that handle text in ym chat windows.This problem happened with Windows7, extra zone in registry is usually small letter "L". Otherwise, some ppl block themselves out of chat response through AVG firewall whitelist setting.

    @prepared4gate ..short of reinstalling windows again. i am thinking of few more tricks. you should try to populate the zones back to the default. those zones should appear as a yellow folder named 0, 1, 2, 3, 4. my Hkey_CU has that folders, and 2 registry entry (default, selfhealcount), Hkey_LM have those zones only.

    1. in IE options, security, try reset all zones to default value, then check restart and see.

    2. get a clean copy of zones registry setting, and update the registry.

    3. uninstall IE, and delete the corrensponding registry settings before installing again. (hkey>software>microsoft>windows>current version>internet settings, and hkey>software>microsoft>internet settings)

    4. try a copy of YM8 (my wishful thinking)

    meddling with services startup is dangerous if you are unsure what you are doing (a perfectly running windows will even fail to boot if u mess with RPC..remote procedure call.. - it says "remote" procedure call?.. must be bad.. kill it..then your heart sunk)

    good luck!

    more reading

    http://forum.networktechs.com/showthread.php?t=928

    http://windowsxp.mvps.org/activescripting.htm

  • If you cannot see text in instant messages, not even your own after you click Send or Press Enter, you are not alone in having this problem. If just a new problem try exiting Yahoo Messenger and then relaunching it. Even try rebooting your computer.

    IMPORTANT: Before trying the suggestions below, first exit Yahoo Messenger by right clicking the Yahoo icon by your clock and choosing Exit. Also close all browser windows. The steps below are safe to do and the purpose is registering scriptings dll's.

    In the Start Menu click on Run. Copy & paste, or type each of the dll's below into the run box, one at a time, and after each one click OK.

    regsvr32 jscript.dll

    regsvr32 vbscript.dll

    Now you can restart Yahoo Messenger and hopefully this problem will be fixed.

    Please Note: For those using Windows Vista or Windows 7 the UAC may need to be turned off and an additional step may be needed for those dll's to be succesfully registered.

    I would appreciate feedback as to whether this works for you. This solution helped dozens of people over a year ago and would like to see if it is still works for people.

  • Amanda
    Lv 4
    4 years ago

    If you're going to ask a question at least be clear. What is this in relation to? A laptop? Blackberry? Iphone? Samsung? Xbox? Playstation? MSN? AIM? YM? You get the idea.. I'd say turn it off and reset it. Usually fixes most things.

  • Anonymous
    9 years ago

    @reizaal: thanks for the help. i had this problem when i upgraded to the latest beta version of yahoo 11. the registry edit trick worked! i had a, extra zone marked as a square symbol. deleted it and restarted yahoo..worked like a charm :).

  • How do you think about the answers? You can sign in to vote the answer.
  • Anonymous
    3 years ago

    sounds weird

  • 4 years ago

    im having the same prob how do i fix it

Still have questions? Get your answers by asking now.