promotion image of download ymail app
Promoted
Robert asked in SportsCycling · 10 years ago

Will SPD cleats work with Crank Brothers Eggbeater Mountain bike pedals?

9 Answers

Relevance
  • AntDU
    Lv 5
    10 years ago
    Favorite Answer

    No. Not all SPD pedals will fit all SPD cleats. Pedals will usually will come with a pair of cleats and they should be used.

    Crank Brothers will use a different cleat. It likely will fit the into the same shoe - but the cleat itself will be different.

    I was set to switch from SPDs to the much lighter Crank Brother pedal, but my road bike uses the same SPD cleat as my mountain bike. In order to change the pedal, I would have had to buy a second pair of shoes (changing cleats is to annoying of an option).

    Source(s): MtBr
    • Commenter avatarLogin to reply the answers
  • Anonymous
    5 years ago

    RE:

    Will SPD cleats work with Crank Brothers Eggbeater Mountain bike pedals?

    Source(s): spd cleats work crank brothers eggbeater mountain bike pedals: https://trimurl.im/g35/will-spd-cleats-work-with-c...
    • Commenter avatarLogin to reply the answers
  • 3 years ago

    Shimano Spd Cleats

    • Commenter avatarLogin to reply the answers
  • 10 years ago

    Crank brothers eggbeater pedals use cleats that are designed for those pedals. Shimano SPD cleats(SPD is a Shimano trademark which stands for Shimano pedaling dynamics) will not work with Eggbeaters. However, Eggbeater cleats will fit the same 2 bolt cleat/shoe interface as SPD cleats.

    • Commenter avatarLogin to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • bardin
    Lv 4
    4 years ago

    Egg Beater Pedals

    • Commenter avatarLogin to reply the answers
  • Anonymous
    10 years ago

    Yes they are SPD compatible. You want the to use the cleats that came with the pedals or are designed for them.

    • Commenter avatarLogin to reply the answers
  • 5 years ago

    where can buy crank brother candy for affordable?

    • Commenter avatarLogin to reply the answers
  • 10 years ago

    No, they are not compatible.

    • Commenter avatarLogin to reply the answers
  • Anonymous
    10 years ago

    no

    wle

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.