Can i install snow leopard?

i just bought a ibook g4 and it has panther on it 10.3 and i wanna get snow leopard 10.5 do i need to install tiger 10.4 first before i can install snow leopard. or i can i just install snow leopard. please help. thanks

3 Answers

Relevance
  • 1 decade ago

    First problem is you FORGOT to mention exactly what you have. What is the processor speed? There were many different iBook G4s.

    Second problem: "snow leopard 10.5" No, it's Snow Leopard 10.6; Leopard 10.5.

    You cannot use OS 10.6 on any PPC Mac, so forget that idea. For anyone else reading this, there is a complex explanation for installing OS 10.6.x when your Intel Mac is running OS 10.4.x, but not related to this guy's iBook, so ask your own question.

    For OS 10.5, here are the requirements:

    * Mac computer with an Intel, PowerPC G5, or PowerPC G4 (867MHz or faster) processor

    * 512MB of memory

    * DVD drive for installation

    * 9GB of available disk space

    * Some features require a compatible Internet service provider; fees may apply.

    * Some features require Apple's MobileMe service; fees apply.

    If your iBook is 800MHz, use LeopardAssist to enable installing Leopard. Bear in mind that an 800MHz system on 10.5 is a bit slower than the same system on 10.4.x.

  • jonis
    Lv 4
    4 years ago

    nicely, this is the terrific to attend till iDeneb or yet another hacked distro would be obtainable with all the non-compulsory installs you like, quite of stressful your self with all the EFI and Bootloader enterprise. For now, you may set up Mac OS X 10.5.8 Leopard by ability of making use of the iDeneb installer (yet be careful, it does not set up like residing house windows, it does not come across the hardware promptly). The Hackintosh communities are working annoying top now to collect all the needed kexts and non-compulsory installs (to be like minded with 10.6). top now, there is the approach to place in leopard and create a 2d partition on which you will set up the SL, yet i come across it to be no longer too complicated, yet messy and stressful. So I propose you may desire to look ahead to yet another week, or much less, till a very sensible hacked distro will pop up, so which you will somewhat do a sparkling set up on your gadget with none concern or annoyance. stable success!

  • 1 decade ago

    The Easy/short answer is NO

    the long answer is yes you need to modify some tables it can be found on what to do in the link below

Still have questions? Get your answers by asking now.