USB write protection removal (Windows 7)?

I bought a brand new USB but I can't copy any files to it because it comes up with the error message "this disk is write protected/please remove write protection". I have searched for a solution and tried all of the following.

1) It does not have a switch on it (I have checked carefully).

2) It won't let me format it.

3) I have been on the registry editor and I do not have a "storage device policies key" therefore no "write protect" option so I cannot set it to zero.

4) I manually made the above key and the "write protect" Dword and I set it to zero but my USB is still write protected.

4) I virus scanned it- no viruses in sight.

5) I tried typing CMD into the "run" on the start menu and typed in the following: "diskpart" then "list volume" to list all the drives on your computer and give them all volume numbers.Then I typed "select volume #" of the disk in question. When I entered "attributes disk clear readonly" it said that it was successful. Then I typed "attributes volume clear readonly" but this didn't work and came up with the error message “not supported on removable media”.

6) I tried downloading some software that my computer said it didn't support.

7) I also tried rebooting my computer in safe mode and tried to format USB using the command prompt window.

Nothing has worked-my USB is STILL (!) write protected.

Any other solutions? I'm getting desperate.

Thanks

1 Answer

Relevance
  • Anonymous
    1 decade ago
    Favorite Answer

    look again, theres a tiny switch on it...get some reading glasses

Still have questions? Get your answers by asking now.