windows 7 internet access problem?

i am using a HP presario cq61, which originally had windows vista installed, but i have recently upgraded to windows 7. When i was using windows vista i was having problems connecting to the internet wirelessly (using my d-link router) and it would connect to the network but only to the internet when it felt like. But if i plugged my laptop directly into the modem it would connect to the internet fine.

Now with windows 7, when i plug it in via ethernet cable, it connects to the network and internet fine.

When i connect it wirelessly, i always get a connection to the network but to get internet access i have to unplug my router for 30 seconds and plug it back in. also if im downloading a file, with a 3 bar signal strength, it disconnects me from the internet but not the network, and i have to unplug the router and back in again to connect to the internet and can only download files when i am sitting right next to the router, which defeats the purpose.

5 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    This is probably due to wireless interference. It's not enough to lose the connection, but causes too many errors for browsing.

    You should try to relocate the router and/or change the wireless channel.

    • Login to reply the answers
  • 1 decade ago

    1- Do you have wireless phone? check the freq. of your phone vs your wireless card. If same range move your phone or router to a different location. or disconnect your wireless phone during testing.

    2- try a different channel on your router and card (they must match).

    3- Look at available wireless networks if any strong signals with same channel switch yours.

    4- upgrade or reflash your router.

    5- Try another wireless card (usb) and see if it works

    6- make sure your router supports your cards band (B,G,N)

    • Login to reply the answers
  • 4 years ago

    take it to a repair shop.. it might be an IP problem you can try resetting you IP(if you know how to get and use IP settings) otherwise all it might be is firewall or if it is not a ligit windows 7...(altleast its all that i can think it migt be)

    • Login to reply the answers
  • 1 decade ago

    your lappy vendor will provide the best answer to this coz i think its a problem with wireless adapter

    • Login to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • 1 decade ago

    try formating it and installing xp

    • Login to reply the answers
Still have questions? Get your answers by asking now.