Belkin Router will not access the Internet...WHY?

My Belkin router will read the host router and it says the signal is Excellent but it still won't connect to the internet. My router can pick up other routers outside my house and i can access the internet fine but it won't connect to the host router. I don't know if its security settings or what but I tried everything from disabling security to downloading service pack 2 and still it doesn't work. Does anyone know why this is happening?? I already got a new Belkin router last week through Belkin so the hardware is not the problem. Please someone HELP!!!!

1 Answer

Relevance
  • 1 decade ago
    Favorite Answer

    Connect to the router via ethernet and access its config page that way FIRST..

    Three reasons:

    -1-

    the router may need a REBOOT or be set to only allow authorised devices (use the router configuration software to change this to off or add the MAC code from the ipod (under the settings ABout page)

    -2-

    the other is because the router is using the WEP protocol instead of WPA or WPA2. In WEP Windows, Linux, Mac OS and iphone OS and Symbian all use differ rent methods for converting passwords to Hex Equivalent log-ins.

    You MUST enter the Hex Equivalent password such as "1C60981433" instead of the password "default" the Hex or Wireless equivalent password is either printed on the router or available via the routers configuration page. WPA and WPA2 do not have this issue as all systems use the common Key /password system

    -3-

    Signal strength, to FIRST connect to a router you need very strong signal (-55 or better {nearer zero]} but once connected you can continue OK until it gets to about −75 then it will often drop out when transmitting but still show weak signal when not being used. if you have this go to settings, Wi-Fi then select the network you are on chose the ‘>’ then select forget this network. go NEXT to the hub then try loggin in again and it should be OK (but remember WEP needs Equivalent and not the password but WPA is OK)

    Also if you have LOTS of local WIFI networks a new wifi being turned on will often obliterate ALL other networks in range until they stabilise and chose a frequency - to avoid this set your WIFI to avoid common channels, 1,6,9,11

Still have questions? Get your answers by asking now.