Yahoo Answers is shutting down on May 4th, 2021 (Eastern Time) and beginning April 20th, 2021 (Eastern Time) the Yahoo Answers website will be in read-only mode. There will be no changes to other Yahoo properties or services, or your Yahoo account. You can find more information about the Yahoo Answers shutdown and how to download your data on this help page.

My computer won't recognize my portable hard drive?

It worked fine then one day it stopped being recognized on my computer. It works fine on other computers but I cant get it back on mine and its a pain because I have all my music from itunes on it. I already tried managing files via my computer and rescanning.

3 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Is this portable USB drive the only USB device that is not working?

    Try this:

    Open Device manager, locate the Universal Serial Bus Controllers, uninstall al of the entries under this heading. Restart the computer. Windows will detect and reinstall the items you uninstalled.

    Good Luck

  • ?
    Lv 4
    4 years ago

    Microsoft domicile windows 2000 and XP customers enter the domicile windows device supervisor by clicking: decide on start up > Settings > administration Panel. Double-click the device icon. click the Hardware tab. click the device supervisor button. In device supervisor you're able to see the USB or 1394 force listed below Disk drives. The USB force could additionally load a Mass storage device below the traditional Serial Bus controllers heading. If the force shows suitable in device supervisor, then proceed to disk administration. If the force shows in device supervisor, yet has a yellow or purple mark, then double-click on the force to be sure the resource of the concern. OneTouch force fashions have a force lock selection. If a OneTouch force is locked it won't take place in device supervisor. in case you think the force is locked deploy the bundled application and it might prompt for a password. i might upload there are numerous distinctive fashions of Maxtor exterior tricky Drives and you probably did not record your kind or your modern-day working device.

  • Anonymous
    1 decade ago

    First try right clicking on everything in USB Controller and Scan For Hardware Changes.

    Then try deleting the Root Hubs.

    Reboot.

Still have questions? Get your answers by asking now.