Internet Explorer Isnt Working. HELP!?

Follow
  • Follow publicly
  • Follow privately
  • Unfollow
haha. y would she download it when u can watch it free! my god u can see anything on the itnernet. geez
Update : Its my friends computer. im just helping. ..so, she had viruses, we ...show more
Best Answer
stop using internet explorer..it sucks. download firefox ..it's faster and doesnt have as many problems
  • Rate
  • Comment

Other Answers (6)

Rated Highest
  • Rated Highest
  • Oldest
  • Newest
  • unsung hero answered 4 years ago
    Use mozilla firefox. Way better than IE.
    • 2
    • Comment
  • ☞The New Slick Rick☜ answered 4 years ago
    I agree with unsung hero, get Firefox it's wheeeey better. I honestly don't miss seeing that crappy "internet explorer cannot find the page you are looking for" message or whatever it was.
    • 1
    • Comment
  • Amir K answered 4 years ago
    all of you keep telling her to change into firefox, i love i too, but maybe she's just stuck into it just like my friend
    Answer: try uninstalling and finding a new installer a IE8 download to make it more faster,easier for you
    try downloading here:
    IE8
    http://www.microsoft.com/windows/interne...

    Source(s):

    • Rate
    • Comment
  • Unicorn answered 4 years ago
    Hi,
    Try following steps to fix crashing IE -

    1. Click on start > control panel > Switch to Classic View > click on Internet options then click on Delete cookies ok, click on Delete files and put a check mark on deleted offline content and click on ok, click on clear history and click on yes.

    2. Again under internet option on the top right click on advanced look for Browsing and under that look for Enable third -party browser extension if it has a check mark uncheck it and then click on apply and OK.

    3. Click on start > run > type in "prefetch" then click on the edit button on the top left click on select all and then press the delete button on the keyboard

    4. Click on start > run > type in "msconfig" under general put a check mark next to selective startup, on the top right click on services at the bottom there is a ok button just above it there is an option called Hide all microsoft services put a check mark next to it and then cleck on disable all and click on apply at the botton right. after that again on the top right click on startup click on startup and click on disable all and click on apply on the botton right and click on close it will ask U to restart the computer so click on restart.

    It might also be a problem with overcongestion or overclogging of your registry with invalid/dead keys, and adware programs on IE. Download and run CCleaner: http://www.ccleaner.com/.

    Also try to get a good anti-malware program like AVG9.0: http://free.avg.com/us-en/download-avg-a... http://www.softpedia.com/get/Antivirus/A... /, http://www.filehippo.com › Anti-Virus/, update and scan your entire drive(s) thoroughly.

    Hope this helps. Have a nice life!
    • Rate
    • Comment
  • Vijay answered 4 years ago
    try to download this and run--

    Source(s):

    • Rate
    • Comment
  • Broski answered 4 years ago
    Stop downloading all that horse pr0n.

    I know it's very arousing, but for the sake of your computer please switch to firefox or get a Mac

    Source(s):

    you know
    • Rate
    • Comment
  • Sign In 

    to add your answer

Who is following this question?

    %
    BEST ANSWERS
    Member Since:
    Points: Points: Level
    Total Answers:
    Points this week:
    Follow
     
    Unfollow
     
    Block
     
    Unblock