I need help with linux?

umm im having a little bit of troule with linux and i was wondering if anybody could help me.

ok im running ubuntu 9.04 netbook remix on my acer aspire one netbook and i tried to switch over to a KDE desktop so i installed the required package and restarted my computer after it was done doing its normal boot it came to the screen where it show the logo and load bar well what it does is it just sits there for a couple of minutes with the "Kubuntu" logo then the screen goes black and i get this message

mountall: symbol lookup error: mountall: undefined symbol: udev_monitor_filter_add_match_subsystem_devtype

init: mountall main process (322) terminated with status 127

if anybody can tell me how to fix this or get by it or just completely remove altogether it would be greatly appreciated

3 Answers

Relevance
  • 1 decade ago

    It kinda sounds like X-Windows crashed really good. You system may not be able to handle KDE. The best way to make sure is to burn of a copy of Kubuntu and see if the LiveCD will load on your netbook. If not that is your problem.

    As for your problem, when you get the error message I would try pressing Ctrl+Alt+Backspace and try to reset X-Windows and more importantly get a login screen. From the login screen you can log back into Ubuntu (netbook). If you system can't handle KDE you will have to stick with Ubuntu (netbook) or you can also try Xubuntu (it is more light weight then even Ubuntu (netbook) but it does have a more Gnome look and feel to it).

  • 1 decade ago

    This has absolutely nothing to do with X. The system is failing to mount the drives properly (access the hard drive partitions) - the only fix I've seen is to use a rescue disk (your Kubuntu install disk will do). Then chroot from the disk to your broken root partition, eg "sudo mkdir /media/sda1; sudo mount -t auto /dev/sda1 /media/sda1; chroot /media/sda1" (depends on your setup, use "fdisk -l /dev/sda" if you're not sure of your root partition, could be on sdb, sdc, sdd too) and complete the "sudo apt-get dist-upgrade".

    YMMV,

    Bug report: https://answers.edge.launchpad.net/ubuntu/+questio...

    Ubu' forums: http://ubuntu-virginia.ubuntuforums.org/showthread... (solution) , http://ubuntuforums.org/showthread.php?t=1309423 (no solution as of now)

  • Anonymous
    1 decade ago

    It is cryptic, but you may find some hints as to what the problem is by examining the file /var/log/Xorg.0.log. If you look at the directory it is in you may see archived logs when Xwindow worked. Comparing the two may help.

Still have questions? Get your answers by asking now.