how to fix the problem on youtube: An error occurred, please try again later?

13 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    If you see the message: "AN ERROR HAS OCCURRED, PLEASE TRY AGAIN LATER"

    which is *INSIDE* an empty Flash player, that's a sign that

    a "time-out" or "run-time" error has occurred. Problems like

    that are usually due to your ISP, YouTube or a network link

    between the two of them which is trying to carry YouTube's

    Flash transmissions onto your computer. These events are

    usually just temporary.

    It's quite possible that simply pressing "F5" (or clicking the

    "Refresh" icon) could easily resolve your problem. You can

    also try clicking the "Back" and "Forward" buttons.

    If your problem is still there, I'm very familiar with "blank" or

    "black" screens -- and have helped hundreds of people with

    with that particular problem. Thus please take a look at my

    previous "Best Answers" (see below) and what the "Askers"

    wrote in their feedback comments to my answer afterwards:

    Not much has changed in the last couple years in terms of

    playing YouTube. If anything, the newest Flash Players are

    causing lots of YouTubers some kind of grief, especially all

    8 variations of version 10. It's crazy that there is a 10.0.525,

    10.1.218, 10.2.26, 10.2.54, 10.12.10, 10.12.36, 10.15.3, as

    well as 10.22.87. Most updates are good for only one thing:

    software conflicts. I have never strayed away from 9.47 and

    many "flashers" still swear that 9.45 is best. Think of those

    two as you would Windows XP, compared to Vista. Please

    look at the Asker's comment to this "Best Answer" of mine:

    http://answers.yahoo.com/question/index?qid=200811...

    If that seems interesting to you, here is the appropriate link:

    http://www.oldapps.com/flash_player.php?old_flash_...

    If nothing seems to resolve your issue, this is what I advise

    people when YouTube gets slow, stuck or weird: clear your

    "cache" of its "Cookies", "History" and "Temporary Internet

    Files". My "CHTIF triple-cure" has resolved literally 100's of

    peoples YouTube problems, so why not yours? Just do the

    following depending on your browser, then shutdown/reboot:

    Internet Explorer 6:

    → Tools → Internet Options

    → Delete Cookies → OK

    → Delete Files → OK

    → Clear History → Yes

    → OK

    Internet Explorer 7:

    → Tools → Internet Options → Delete...

    → Delete files → Yes

    → Delete cookies → OK

    → Delete history → OK

    → Close (browsing history window)

    → OK

    Internet Explorer 8:

    → Tools → Delete Browsing History

    [. ] Preserve Favorites (leave blank)

    [x] Temporary Internet files

    [x] Cookies

    [x] History

    → Delete

    Mozilla Firefox 3:

    → Tools → Clear Private Data

    [x] Browsing History

    [x] Download History

    [x] Saved Form and Search History

    [x] Cache

    [x] Cookies

    → Clear Private Data Now

    Mozilla Firefox 3.5:

    → Tools → Clear Recent History

    Time range to clear: → Everything

    ▼ Details

    [x] Browsing & Download History

    [x] Saved Form and Search History

    [x] Cookies

    [x] Cache

    → Clear Now

    Apple Safari 3:

    → Edit → Preferences

    → Security (tab) → Show Cookies

    → Remove All → Done

    after that:

    → Safari → Empty Cache → Empty

    after that:

    → History → Clear History

    Google Chrome:

    → Tools (wrench) → Clear browsing data...

    [x] Clear browsing history

    [x] Clear download history

    [x] Empty the cache

    [x] Delete cookies

    Clear data from this period: → Everything

    → Clear Browsing Data

    http://answers.yahoo.com/question/index?qid=200903... (blank)

    best answer by a mile. MY YOUTUBES BACK.

    http://answers.yahoo.com/question/index?qid=200902... (blank)

    Thanks for all that, it worked !!

    http://answers.yahoo.com/question/index?qid=200902... (blank)

    dude, thanks!! clearing my "cache" worked! Thanks for your time and all.. =)

    http://answers.yahoo.com/question/index?qid=200906... (error)

    thanks alot it worked

    http://answers.yahoo.com/question/index?qid=200905... (error)

    this is exactly what i did and it worked :] ---- thank youuu!!!

    • John5 years agoReport

      THANK YOU!!!!!!!!!!!!!!!

    • Commenter avatarLogin to reply the answers
  • Anonymous
    4 years ago

    Youtube An Error Occurred

    • Commenter avatarLogin to reply the answers
  • 6 years ago

    Tried the above solution. Did not work for me. What did work however, was downloading and installing the latest java software. I did this because I also noticed unreadable text when opening various links. Thought this had to be a problem with Java and apparently I was right. The bonus came when I checked my youtube video problem and discovered that it was fixed as well. Hooray! Don't know why or how.

    • Commenter avatarLogin to reply the answers
  • 5 years ago

    Best Youtube Error Occurred Solution http://goo.gl/ugKVhe

    • Commenter avatarLogin to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • 6 years ago

    THIS IS A CONTINUATION FROM MY LAST POST. For some reason I could not post another "Comment" so please read my entire posts, then continue from my last "COMMENT"

    Now, under the "sound" tab, click "change system sound" a window will open, click "playback" now click "AMD HDMI Output" now, at bottom, right side, click "properties" You will see ( Device Usage) click "use this device (enable) now select "Don't Use This Device ( Disable ) now click "Apply" then click "OK"

    Now you are back in the (Sound ) window again. This time, click "speakers" then go down to the bottom right again, and click "Properties" Again, you'll see ( Device Usage ) Click the arrow, and select "Use This Device ( Enable )" Click "Apply" then click "OK" Now, close your control panel, and you should be golden.

    If you want to watch TV through your computer or laptop, hook up your HDMI cable, and go back to your control panel, and go through these steps again, however, you will be disabling "Speakers" and Enabling "

    your ADM HDMI Cable, and Disabling your "Speakers"

    Please let us know if this simple fix worked for you.

    As I stated, I tried every fix solution I could find via Google searches, and nothing worked, until I read a comment someone made, about how he had Disabled his speakers, and immediately, he could no longer get any videos to stream at all. He was pondering, about that being a coincidence, however, he did not post anything after that. So, I thought, "well....maybe, just MAYBE, this could be the problem. It was easy enough to try, and it actually worked!!!

    I truly hope this simple "fix?" works, because a lot...a LOT of people were seriously cheesed, and nothing they attempted, was a fix. So, even if you're thinking this sounds to easy to work, and after you've gone through all the setting changes, and switched things on and switched things off, and restarting, and tearing out your hair off your skull, adding to the teeth gritting frustration, you now are the proud new recipient, of an authentic Skullit!!! Noooooooooo!!! Dude, don't talk yourself into thinking it looks cool, or it suits you...it doesn't, man-up and shave it all off! Do not do a Jessie Ventura!! Hey, I love you Ventura, but your Skullit does way more damage than your wrestling, and Frog Man abilities ever did!!

    • Commenter avatarLogin to reply the answers
  • 5 years ago

    From what I have been reading there might be a number of things that may be causing this problem. What resolved this issue for me was updating my internet time server. It seemed my date setting was wrong and as such my certificates weren t up to date: Double click on the time in the bottom right of the screen, go to internet time and click update now, once it synchronize successfully reload page.

    • Commenter avatarLogin to reply the answers
  • 5 years ago

    I had the same problem .. and tried all the solutions did not work .... I finally found the solution

     The problem in the system clock ... when tuning the system clock with the current time, the problem disappeared...

    • Commenter avatarLogin to reply the answers
  • 5 years ago

    The Internet clock trick worked for me.

    • Commenter avatarLogin to reply the answers
  • 4 years ago

    Check if you have disabled your speakers. If yes, enable them. It worked for me and possibly may work for you too.

  • 5 years ago

    sos,,what a bullshit./// try this.,,adjust the time to exact time,,then thats it, try to play again youtube. this method help me.

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.