LINUX灌PHP5.3.0

小妹我不懂LINUS只好照著書說的灌PHP

但卻發生以下問題

我重慣很多次apache都沒問題 確實有apxs檔案

都是在要慣php時發生錯誤

請告訴我哪邊出了問題 才會一直無法灌成功呢?

謝謝

www2# ./configure --with-mysql --with-apxs=/usr/local/apache/bin/apxs\ --prefix=/usr/local/php

loading cache ./config.cache

checking for Cygwin environment... no

checking for mingw32 environment... no

checking for egrep... grep -E

checking for a sed that does not truncate output... /usr/bin/sed

checking host system type... i386-unknown-freebsd6.2

checking target system type... i386-unknown-freebsd6.2

checking for gcc... gcc

checking whether the C compiler (gcc ) works... yes

checking whether the C compiler (gcc ) is a cross-compiler... no

checking whether we are using GNU C... yes

checking whether gcc accepts -g... yes

checking how to run the C preprocessor... gcc -E

checking for icc... no

checking for suncc... no

checking whether gcc and cc understand -c and -o together... yes

checking how to run the C preprocessor... gcc -E

checking for AIX... no

checking whether ln -s works... yes

checking for system library directory... lib

checking whether to enable runpaths... yes

checking if compiler supports -R... yes

checking for gawk... no

checking for nawk... nawk

checking if nawk is broken... no

checking for bison... no

checking for byacc... byacc

checking for bison version... bison: not found

invalid

configure: warning: bison versions supported for regeneration of the Zend/PHP parsers: 1.28 1.35 1.75 1.875 2.0 2.1 2.2 2.3 2.4 2.4.1 (found: none).

checking for re2c... no

configure: warning: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.

checking whether to enable computed goto gcc extension with re2c... no

checking whether to force non-PIC code in shared modules... yes

checking whether /dev/urandom exists... yes

checking for pthreads_cflags... -pthread

checking for pthreads_lib...

Configuring SAPI modules

checking for AOLserver support... no

checking for Apache 1.x module support via DSO through APXS...

Update:

後半是

Sorry, I was not able to successfully run APXS. Possible reasons:

1. Perl is not installed;

2. Apache was not compiled with DSO support (--enable-module=so);

3. 'apxs' is not in your path. Try to use --with-apxs=/path/to/apxs

Update 2:

最後

The output of /usr/local/apache/bin/apxs --prefix=/usr/local/php follows

./configure: /usr/local/apache/bin/apxs: not found

configure: error: Aborting

Update 3:

因為老闆希望我學,我同事很忙就把整個主機丟給我任意玩

我正在霧裡看花

是否重灌Linux會比較快速?

另外這個系統已經灌過mysql,php等

因為舊的php不支援unit 8 所以我才想更新php

如果我用您說的套件灌 會不會讓我之前的資料庫資料都不見了呢?

我的書很舊 沒有寫那麼多 不過我會試試您說的

謝謝

2 Answers

Rating
  • 1 decade ago
    Favorite Answer

    您好,誠摯的來回答您的問題:

    有可能是因為 您沒有在 make 之前,include PHP 的問題,

    您硬要這樣做,意思是說 您要用 configure、make、make install

    當然是可以的,不過 所需要的功力,高很多

    因為您是說您用 Linux,

    但是看到您使用的 Linux 版本是 freebsd,

    既然這樣,而且您也有書本,

    可以直接使用 freebsd 當中的 apt 線上安裝 & 更新套件呀!!

    您的書應該有寫這塊吧!!

    直接使用 線上安裝 & 更新,就可以直接把 apache + php + mysql 安裝好囉!

    dependence 問題,apt 會自己解決,

    所以也沒有這些有的沒的問題,

    但是,在下 挺佩服您的 因為 freebsd 這比較不好安裝,

    很多東西確實需要自己 make,對初學者來說,難度高許多

    以上 AYO 阿佑

    2009-09-02 17:11:10 補充:

    跟您說明一件事情,

    如果是伺服器裡面有東西,仍然需要,

    例如: 您說的資料庫,

    不論如何,請先把需要的東西全部備份出來,

    這才是首要的,

    理由: 小心能駛萬年船不是嗎?? 因此不論如何,需要的東西全部備份!

    之後,不論您如何胡搞瞎搞,就算主機不得不重裝,

    您也沒差呀!

    PS: mysql 一般都是在 /var/lib/mysql 這個目錄,請記得備份

    2009-09-02 17:11:53 補充:

    再來就是,不知道您 Boss,僅說 希望您學 Linux,還是說一定要搞 FreeBSD,

    基本上,會喜歡玩 FreeBSD 理論上都是 學術界出身的,

    但是講真的,您是新手的狀況,就直接摸 FreeBSD 您會很痛,

    到不如玩玩 Fedora 會比較舒服點,

    但是別去玩更簡單的 Ubuntu,那一定會被您老闆罵,

    不過端看貴公司對 Linux 方面的指定啦!

    2009-09-02 17:12:29 補充:

    書舊 沒關係,在下只想幫助有上進心的人 (當然不論您是男是女),

    這個是 小紅魔 FreeBSD 國際站台,這邊有最新版的 FreeBSD 可以下載

    http://www.freebsd.org/

    這個是 很有名的維基百科,講述 FreeBSD 的起源,您可以看看

    http://zh.wikipedia.org/wiki/FreeBSD

    這是 FreeBSD 中文站台,裡面有非常詳盡的介紹,

    並且都是新的,純中文的,沒有閱讀的困難

    http://www.twbsd.org/cht/book/

    2009-09-02 17:12:36 補充:

    能實際上幫到您的,就只有這些了,剩下的就看您囉!

    不過,真的難為您了! 但是請加油囉! 既然是老闆指定 莫法度

    以上 AYO 阿佑

    Source(s): 自己+業界多年經驗+電腦週邊急救團, 自己+業界多年經驗, 自己+業界多年經驗, 自己+業界多年經驗, 自己+業界多年經驗
  • 1 decade ago

    From the error messages, you will at least the following problems:

    1. bison not found, bison is the free version of yacc

    2. your apache compilation needs to have use modules for PHP, this is true only with apache 1.X. Apache version will not need this.

    2009-09-03 04:48:29 補充:

    3. You may have to consider the order of compilation. That is mysql, php and apache need to be compiled in certain orders (SSL will make it more complicated.

    4. Apache 2 will need linux kernel version 2.4 or higher.

    5. Versions of mysql, apache and php make some differences.

    2009-09-03 04:49:38 補充:

    6. The options to enable and disable will also make some differences.

    7. You may consider installing the software from RPMs install of from compiling the source.

Still have questions? Get your answers by asking now.