Anonymous
Anonymous asked in Computers & InternetHardwareDesktops · 1 decade ago

help !! my motherboard won't detect drives as master only as slave?

will not show up during the POST screen as master. When I set the jumper to master it doesn't detect the drive at all and gives me an error message, "NTDLSR missing" or something similar. Set it to slave and it detects it but says "master drive failure. Press F1 to continue or delete to enter setup" Press F1 and it boots right into windows XP and everything is fine. It's just annoying that I can't set it to master and have to press F1 everytime I want to use it. Could this be a BIOS issue and I need an update or something wrong with the HDD? or the motherboard itself ? Thanks for any and all help

Update:

my motherboard won't detect drives as master only as slave on both ide channels even the jumpers are correctly installed, i had tried to set

up several hard drives and some optical drives but the same problem

presists (it won't detect primary master and secondary master)

here are my system specs...

Asus P5L-VM 1394 Motherboard

Maxtor 80GB+Seagate 160GB+Samsung 40GB HDDs

Sony DVD/RW Drive

Intel Core 2 Duo E4600 CPU

2GB of DDR2 Memory

256MB ATI Radeon HD 2600XT

Cooler Master 460w PSU

Update 2:

@WindZero,

Sir im using all PATA HDD/Optical drives

and i assure you that detection problem

is coming with my motherboard the cables and jumpers are OK i had

also cleared CMOS and also updated

the BIOS but the problem presists

2 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    Can you tell me which hard drives are PATA (IDE) and SATA?

    (I am assuming that the SATA drive is the Samsung 160GB)

    Which drive are you wanting to use for boot?

    Is your optical drive SATA as well?

    Finally, tell me on which SATA ports are your drives hooked up to.

    After that, I will come back and edit my post, and hopefully I might be able to help you.

    Sorry, for needing a little more info.

    EDIT - Try this...since you are using all PATA drives check in the BIOS Setup Menu in Main.

    Look for IDE configuration

    Open "Onboard IDE Operate Mode (Enhanced IDE)

    Try setting the Enhanced Support Mode on to P-ATA

    This might clear it up as it forces the motherboard to only see P-ATA drives.

    If that does not work, set the Onboard IDE Operate Mode to Compatibility/Legacy Mode.

    I am banking on the assumption that it wants to give priority to SATA drives only and ignoring the PATA drives.

    2nd edit - If that does not work...just add more to your additional details or whatever, and I can try and find something else.

    or

    You may have to look into a IDE to SATA adapter connector.

    http://www.newegg.com/Product/Product.aspx?Item=N8...

    Set that to your master jumpered drive, renable your Onboard IDE Operate Mode back to Enhanced, Set your Enhanced Support Mode to S-ATA+P-ATA, ...use the converted drive and place it in SATA Port 1/2 (manual states that those ports correspond to the Master portion.) and run it that way.

    or

    Get a newer SATA hard drive....newer ones under 1TB are pretty cheap...even a 1TB is less than 100 dollars.

    (Although I do understand you trying to use what you have on you.---"If it still works, why not use what works until it runs into the ground.")

    Source(s): Looking between the ASUS Manual PDF and installation and ASUS forums concerning SATA and PATA drives for installations of operating systems
  • 1 decade ago

    1. are you sure you have the drive(s) in the correct place on the mainboard.here will be a primary and secondary connection. If using a cable ensure that the primary drive is connected first and the secondary on the connector down the cable.

    2. Set the drive as master and enter the BIOS at startup by tapping probably the delete key (sometimes another that is shown on the screen)

    3. Select the drives and look at their master slave relationship there.

Still have questions? Get your answers by asking now.