Anonymous
Anonymous asked in Cars & TransportationCar MakesChrysler · 1 decade ago

Chrysler LHS auto temp control problems?

My 99 chrysler LHS auto climate control is acting strange. When it is set to auto, the AC is on no matter what I have the temp set to. The blend door opens sometimes for a second, and hot air comes out, but then it goes right back to cold. Set to manual, it still only blows cold air. I have performed the test to display bcm trouble codes, and nothing happens. No codes display, and the atc unit doesn't even start blinking. I am thinking that the bcm is bad. This is not the first electrical problem I have had. Where is the bcm located? Could this be the problem? How do I reset the bcm?

4 Answers

Relevance
  • 1 decade ago
    Best Answer

    I'd first try resetting the comps disconnect the battery for a good 20 mins then see how the system acts.Can't recall exactly on those but I think the BCM is on the passengers right side by their legs behind the plastic side panelling and several screws must be removed including a torque head screw that mounts the BCM.

    If you try resetting the comp system and then still you've problems I'd have a full free scan performed on that vehicle.Getting another BCM that's used is my suggestion to you , plus you could ask the U pick auto wreckers where and how to remove the BCM too.

    Hope that helps and best of luck.By the way be sure the BCM you get is from a car like yours , same engine , transmission but most importantly the vehicle you take it out of has the same interior features such as the same heat A/C system setup and if your has cruise control be sure it does too.

    Dodge uses thin or poor quality wiring and be sure you check the grounds going to the BCM etc bec that is a common problem too, also some parts stores offer free print outs of the BCM pin chart that has the wiring color code and also they offer schematic print outs etc.

  • lawn
    Lv 4
    3 years ago

    1997 Chrysler Lhs Problems

  • 4 years ago

    If your cruise light is coming on that's good, it means that electricly, it's okay. The most common problem is a vacuum leak. Check all the vacuum lines going to the cruise servo under the hood. Pull the vaccum line off of the servo ( with the engine running ) and put your finger over it. Can you feel the vacuum? It should be pretty strong. Give that a try :)

  • C-Tech
    Lv 6
    1 decade ago

    These are expensive parts you are talking about throwing around. Please pay the dealer or a shop to scan the system and get the codes. Listen to their repairs suggestions then proceed. Good luck.

    Source(s): Chrysler tech 10+ years
Still have questions? Get your answers by asking now.