Subwoofer stopped working whats wrong?

I was on my way home and all of a sudden my 2 orion subwoofers stopped working.I checked the amp and the light is on so I took the subs inside to hook them up inside and nothing neither one works.What could have happend and what can I do?

Update:

What does frozen mean. Can I fix them

also how can I tell if they are frozen.I don't know alot about this so please help.The both dont work they don't smell

burned or anything

Update 2:

Okay I pushed down and they seem fine

There is no noise or rubbing.

5 Answers

Relevance
  • 1 decade ago
    Best Answer

    sounds like uve frozen the subs

  • 1 decade ago

    It sounds like you fried your subs. What will happen is they will stop working however it is pretty weird that they both went at the same time. I would suggest running a direct wire without an amp to each sub not the box but to each sub. If they work then something is jacked up in your box or amp. If not then your voicecoils are fried. I would suggest something other then orion for your new ones. No offense but they are not really very good.

  • Anonymous
    1 decade ago

    lightly push down on the center of the subwoofers. they should move in and out without any restrictions or rubbing. if it feels like they are rubbing something, chances are they are blown and need to be replaced.

  • 4 years ago

    Touch the two leads of a multimeter set on the ohm-setting across the speaker terminals, if you get 2, 4, or 8 ohms then the woofer aint the problem.

  • How do you think about the answers? You can sign in to vote the answer.
  • 1 decade ago

    you might have blown your voice coils

Still have questions? Get your answers by asking now.